Closed Bug 973782 Opened 6 years ago Closed 5 years ago

Intermittent test_bug938022.html | currentTime must be zero

Categories

(Core :: Web Audio, defect, P1)

ARM
Android
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: philor, Assigned: karlt)

References

Details

(Keywords: intermittent-failure)

Not a good sign, failing on the push immediately after it lands.

https://tbpl.mozilla.org/php/getParsedLog.php?id=34822117&tree=Mozilla-Inbound
Android 2.2 Armv6 Tegra mozilla-inbound opt test mochitest-4 on 2014-02-17 21:59:03 PST for push dfa1bf6d4c60
slave: tegra-238

63 INFO TEST-START | /tests/content/media/webaudio/test/test_bug938022.html
64 ERROR TEST-UNEXPECTED-FAIL | /tests/content/media/webaudio/test/test_bug938022.html | currentTime must be zero
65 INFO TEST-INFO | MEMORY STAT vsize after test: 553451520
66 INFO TEST-INFO | MEMORY STAT residentFast after test: 147103744
67 INFO TEST-INFO | MEMORY STAT heapAllocated after test: 25463268
68 INFO TEST-END | /tests/content/media/webaudio/test/test_bug938022.html | finished in 301ms
Chris would you expect the test in https://hg.mozilla.org/integration/mozilla-inbound/rev/8e574d7a951a to always pass?
Do you know whether this is a bug in the test or implementation?
Flags: needinfo?(cpearce)
I would expect that test to be almost perma-orange. The "playing" event should fire after playback has started; after the current time has started advancing, i.e. is non-zero. The test is bad.
Flags: needinfo?(cpearce)
Duplicate of this bug: 973796
Need to back out this version too.
Priority: -- → P1
Assignee: nobody → karlt
Closing bugs where TBPLbot has previously commented, but have now not been modified for >3 months & do not contain the whiteboard strings for disabled/annotated tests or use the keyword leave-open. Filter on: mass-intermittent-bug-closure-2014-07
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.