Closed Bug 973855 Opened 6 years ago Closed 6 years ago

[Australis] Bottom border of content area in customization mode misplaced or missing

Categories

(Firefox :: Toolbars and Customization, defect)

All
Windows 7
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 31
Tracking Status
firefox29 --- verified
firefox30 --- verified
firefox31 --- verified

People

(Reporter: pretzer, Assigned: MattN)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [Australis:P4-])

Attachments

(2 files, 1 obsolete file)

When switching to customization mode the bottom border of the content area stays where it is and does animate upwards with the content. Instead it is visible in the glass area at the bottom. I reproduced this on Win7, not sure if other platforms are affected.
Attached image Screenshot of the issue
I think there's one or more negations missing in:

When switching to customization mode the bottom border of the content area stays where it is and does animate upwards with the content. Instead it is visible in the glass area at the bottom.


Orthogonally, can you reproduce this in safe mode, and/or is this a dupe of bug 970998?
Flags: needinfo?(telcharion)
(In reply to :Gijs Kruitbosch from comment #2)
> I think there's one or more negations missing in:
Indeed! What I meant was: "... does *NOT* animate upwards ..."

> Orthogonally, can you reproduce this in safe mode, 
Yes, I can reproduce in safe mode.

> and/or is this a dupe of bug 970998?
Does not seem like a dupe to me. That bug is talking about the missing animation, which is intentional AFAICS. I'm talking about a visual glitch, that is probably not intentional.
Flags: needinfo?(telcharion)
Whiteboard: [Australis:P?] → [Australis:P4-]
Duplicate of this bug: 989681
henryfhchan has a solution in bug 989681 comment 0.
henryfhchan, are you able to submit patches? See http://codefirefox.com/ and/or https://developer.mozilla.org/en-US/docs/Introduction
Assignee: nobody → henry.fai.hang.chan
Flags: needinfo?(henry.fai.hang.chan)
(In reply to henryfhchan from bug 989681 comment #6)
> Sorry, I haven't written a patch before, and seems like I don't have enough
> disk space to install the related tools...

OK, I'll make it for you if you can test it.
Assignee: henry.fai.hang.chan → MattN+bmo
Status: NEW → ASSIGNED
Flags: needinfo?(henry.fai.hang.chan)
The border is missing altogether outside -moz-windows-compositor. I'll get a separate bug on file for that.
Summary: [Australis] Bottom border of content area in customization mode misplaced → [Australis] Bottom border of content area in customization mode misplaced with DWM
Of course it wasn't so easy.

Despite bug 962677 not including the developer toolbar, I think it should be included in the customization mode padding along with the rest of browser-bottombox since that's where extensions put bottom toolbars (e.g. add-on/status bar replacements) and I think it makes sense for it to shrink along with the rest of the toolbars in customization mode.

Tested on Windows 7, 10.9 HiDPI and Ubuntu x64 but I want to do another sanity check before requesting review since it's late.
Comment on attachment 8399052 [details] [diff] [review]
WIP - Include browser-bottombox in the customization mode padding

Review of attachment 8399052 [details] [diff] [review]:
-----------------------------------------------------------------

Were there no Windows-specific changes needed? Do you know how this may affect CART? Otherwise, this change looks good, and it has the added benefit of keeping the Developer Toolbar connected to the rest of the content portion of the window when in customization mode.
Attachment #8399052 - Flags: feedback?(jaws) → feedback+
Summary: [Australis] Bottom border of content area in customization mode misplaced with DWM → [Australis] Bottom border of content area in customization mode misplaced or missing
(In reply to Jared Wein [:jaws] from comment #10)
> Review of attachment 8399052 [details] [diff] [review]:
>
> Were there no Windows-specific changes needed? 

Now that I tested with non-Aero, I have a fix for it too and it fixes comment 8 which I was originally going to do in a separate bug. (The patch was a WIP for feedback because I hadn't manually tested as much as I wanted to).

> Do you know how this may affect CART?

We'll find out:

Baseline: https://tbpl.mozilla.org/?tree=Try&rev=feb96cf59e30
Patch: https://tbpl.mozilla.org/?tree=Try&rev=91b5642bbfc3

Comparison: http://compare-talos.mattn.ca/?oldRevs=feb96cf59e30&newRev=91b5642bbfc3&submit=true
Attachment #8399052 - Attachment is obsolete: true
Attachment #8401181 - Flags: review?(jaws)
Comment on attachment 8401181 [details] [diff] [review]
v.1 Include browser-bottombox in the customization mode padding

Review of attachment 8401181 [details] [diff] [review]:
-----------------------------------------------------------------

CART results look fine, only a teeny-tiny regression (.66%) on Win7.
Attachment #8401181 - Flags: review?(jaws) → review+
https://hg.mozilla.org/integration/fx-team/rev/5cb220a0c88f
Keywords: checkin-needed
Whiteboard: [Australis:P4-] → [Australis:P4-][fixed-in-fx-team]
Comment on attachment 8401181 [details] [diff] [review]
v.1 Include browser-bottombox in the customization mode padding

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 873060
User impact if declined: There will be a floating detached bottom border with DWM in customization mode and no bottom border without DWM. This also makes it so that toolbars on the bottom of the browser contract with the rest of the toolbars which is more consistent IMO.
Testing completed (on m-c, etc.): m-c soon
Risk to taking this patch (and alternatives if risky): Low risk CSS changes to margin and border.
String or IDL/UUID changes made by this patch: None
Attachment #8401181 - Flags: approval-mozilla-beta?
Attachment #8401181 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/5cb220a0c88f
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P4-][fixed-in-fx-team] → [Australis:P4-]
Target Milestone: --- → Firefox 31
Attachment #8401181 - Flags: approval-mozilla-beta?
Attachment #8401181 - Flags: approval-mozilla-beta+
Attachment #8401181 - Flags: approval-mozilla-aurora?
Attachment #8401181 - Flags: approval-mozilla-aurora+
Status: RESOLVED → VERIFIED
I was able to confirm the fix for this issue on Windows 7 64-bit [1] using:
- the latest Beta (Build ID: 20140407135746),
- the latest Aurora 2014-04-07 (Build ID: 20140407004002),
- the latest Nightly 2014-04-07 (Build ID: 20140407030203).


1. Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0
You need to log in before you can comment on or make changes to this bug.