URL bar does not autocomplete

VERIFIED WORKSFORME

Status

SeaMonkey
Location Bar
VERIFIED WORKSFORME
17 years ago
10 years ago

People

(Reporter: Rainer Mager, Assigned: Alec Flett)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3+) Gecko/20010814
BuildID:    20010829

When typing in an URL it is not auto completed. This used to work a few weeks
ago but recent builds seem to have broken it.

Reproducible: Always
Steps to Reproduce:
1. type in an URL
2.
3.

Actual Results:  No auto completion.

Expected Results:  Auto completion.
This sounds a lot like bug 94870.  Since your build ID does not even exist at
the time I'm writing this, I am looking at your user agent string Gecko date as
a reference (the 14th).  That bug existed from about the 11th thru the 21st so
it should be fixed in newer version.

Marking a dupe but if this still occurs in a brand new build, please reopen this
bug.

*** This bug has been marked as a duplicate of 94870 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

17 years ago
Sorry, by build is from the latest CVS as of 20010829.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 3

17 years ago
is there a more precise testcase?
(Reporter)

Comment 4

17 years ago
Hmm. Basically, no matter what I do the URL bar does not show any 
autocompletions. I don't know what else to test. I've tried prefixing URLs with 
http:// or without and it makes no difference.
->URL Bar

I'm using a brand new linux build myself (2001082822) and things work fine in
auto complete.  Can you try it with a new profile and see if that fixes it?
Assignee: pchen → alecf
Component: XP Apps → URL Bar
QA Contact: sairuh → claudius

Comment 6

17 years ago
WFM with a current CVS build, more recent than reporter's. I also commented in
bug 97419.
(Reporter)

Comment 7

17 years ago
What do you mean by "a new profile" and how would I do this?
(Reporter)

Comment 8

17 years ago
Ok. I did a complete rebuild (clobber_all then make again). And this now works now.

My new question is, should I always do a clobber? When is it ok not to?

Marking WFM as per the reporter's own comments.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WORKSFORME

Comment 10

17 years ago
Re: clobber
No, it's not necessary to clobber every time you build, if you build regularly.
If you build on a daily basis i'd suggest clobbering every other week, if you
build once every week or so, i'd suggest clobbering every time.
Though theoretically it shouldn't matter, there may be changes that don't get
picked up right on depend builds. I'm not sure when this applies or not, because
i build from a clean tree every time (seperated cvs tree and build tree), but
that's just me. (I build on windows)
Re: new profile
You were asked to start with a new profile. This can be done in 2 ways; first:
move or delete you profile, which would be in ~/.mozilla, and then restart
mozilla. Second: starts mozilla with the profilemanager (ie. run mozilla
-profilemanager) and create a new profile. (Not sure about the 2nd one in linux)

Hope this helps a bit.

Comment 11

17 years ago
VERIFIED WFM
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.