Closed Bug 974246 Opened 7 years ago Closed 7 years ago

Find file in build_stage if it doesn't exist in app directory

Categories

(Firefox OS Graveyard :: Gaia, defect)

x86
macOS
defect
Not set
normal

Tracking

(b2g-v1.4 fixed)

RESOLVED FIXED
1.4 S2 (28feb)
Tracking Status
b2g-v1.4 --- fixed

People

(Reporter: yurenju, Assigned: timdream)

References

Details

(Keywords: regression)

Attachments

(1 file)

after bug 968684 was landed, we no longer get HOMESCREEN/js/init.json, find files in build_stage if it doesn't exist could solve this issue.
Taken, patch ready.
Assignee: nobody → timdream
Comment on attachment 8378048 [details] [review]
mozilla-b2g:master PR#16434

For the record, I don't like the solution here. However at least it fixes the breakage of DEBUG=1 profile, for now.

Let's think harder on for a proper stage 2 plan.
Attachment #8378048 - Flags: review?(yurenju.mozilla)
Comment on attachment 8378048 [details] [review]
mozilla-b2g:master PR#16434

r=yurenju, thanks!
Attachment #8378048 - Flags: review?(yurenju.mozilla) → review+
Marking regression because this breaks DEBUG=1 Desktop development flow, if user did |git clean| after bug 968684.

Marking checkin-needed because the tree is currently closed.
Status: NEW → ASSIGNED
Master: 1f7880fc1f1eefeeff5d94d50db047ff3327bb22
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 1.4 S2 (28feb)
You need to log in before you can comment on or make changes to this bug.