Closed Bug 974430 Opened 6 years ago Closed 6 years ago

Put the |input[type=number]| rule in forms.css into a separate sheet so we can make it respect to the dom.forms.number pref

Categories

(Core :: DOM: Core & HTML, defect, P1)

29 Branch
defect

Tracking

()

RESOLVED FIXED
mozilla30
Tracking Status
firefox29 + fixed
firefox30 --- fixed

People

(Reporter: jwatt, Assigned: jwatt)

References

Details

Attachments

(1 file)

We should put the |input[type=number]| rule in forms.css into a separate sheet so we can make it respect to the dom.forms.number pref. Ideally we'd solve the issue by fixing bug 677302, but that doesn't have agreement on the way to go and we need this for v29 (currently Aurora).
Attached patch patchSplinter Review
Attachment #8378343 - Flags: review?(dbaron)
Why not move all of those rules to number-control.css?  That makes it easier to find them all in the same place.
Because this is a workaround for the lack of a fix for bug 677302 that I hope to revert sooner rather than later. Besides that no point messing up blame, or causing confusion about what _needs_ to be in this other sheet.
Alright, fair enough!
Comment on attachment 8378343 [details] [diff] [review]
patch

nsDocumentViewer.cpp:

  Don't you want to put the code before the code for FormsSheet, so that
  it ends up after FormsSheet in the cascade?

  (I suppose technically there's no difference, but it seems better that 
  way.)

jar.mn:

>+*  res/number-control.css    (number-control.css)

No need to preprocess the file (i.e., remove the "*").

nsLayoutStylesheetCache.h:

>+  static nsCSSStyleSheet* NumberControlSheet();

Please comment that this is expected to return null when the number 
control is disabled.

r=dbaron with that
Attachment #8378343 - Flags: review?(dbaron) → review+
Comment on attachment 8378343 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 344616
User impact if declined: risk of number related issues/crashes like bug  	973344
Testing completed (on m-c, etc.): landed on m-i, passed tests and will merge to m-c soon
Risk to taking this patch (and alternatives if risky): should be low, at least low enough for aurora
String or IDL/UUID changes made by this patch: none
Attachment #8378343 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/f92329a2b0b5
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla30
Attachment #8378343 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Depends on: 1135622
Blocks: 1317541
You need to log in before you can comment on or make changes to this bug.