Closed Bug 974495 Opened 6 years ago Closed 6 years ago

crash in mozalloc_abort(char const*) | abort | mozilla::DOMCameraControlListener::DOMCallback::Run()

Categories

(Firefox OS Graveyard :: Gaia::Camera, defect, critical)

ARM
Gonk (Firefox OS)
defect
Not set
critical

Tracking

(blocking-b2g:1.4+, b2g-v1.4 fixed)

VERIFIED FIXED
1.4 S2 (28feb)
blocking-b2g 1.4+
Tracking Status
b2g-v1.4 --- fixed

People

(Reporter: astole, Assigned: mikeh)

References

()

Details

(4 keywords, Whiteboard: [b2g-crash])

Crash Data

This bug was filed from the Socorro interface and is 
report bp-68f986a8-0b14-4ade-a777-67d8e2140219.
=============================================================

Repro Steps:
1) Updated Buri to BuildID: 20140219040204
2) Open the Camera app
3) Switch from Camera mode to Video mode then Camera icon
4) Completely close out of Camera app by long pressing home button
5) Re-open Camera app
6) Select video mode

Actual Results:
Camera app crashes after closing and restarting then selecting video again.

Environmental Variables:
Device: Buri v1.4 Mozilla RIL
BuildID: 20140219040204
Gaia: ac06cfbd2baf6494ffbb668cc599e3892cd5e17b
Gecko: bf0e76f2a7d4
Version: 30.0a1
Firmware Version: V1.2-device.cfg
Attached URL of video for repro steps.

Also, on some occasions, the app had to be closed by tapping the home button, re-opened, then closed by long pressing the home button and when the Camera app is re-opened again, it crashes.
Unable to launch camera after hitting this crash (will keep crashing), have to restart device to recover.
Related to bug 973790?
blocking-b2g: --- → 1.4?
Keywords: smoketest
Keywords: reproducible
Keywords: regression
Whiteboard: [b2g-crash]
Assignee: nobody → mhabicher
The additional tests in bug 940424 exposed this issue, and the fix is part of that patch.

aggregate try-server push: https://tbpl.mozilla.org/?tree=Try&rev=7b84eb4f5490&showall=1
Depends on: 940424
Crash issues should be blockers, aren't they?
Duplicate of this bug: 974851
Is bug 974855 the same issue ?
(In reply to Julien Wajsberg [:julienw] from comment #6)
>
> Is bug 974855 the same issue ?

I wouldn't think so, but I just tested on Inari running the latest nightly, and it seems to work: I can successfully attach a newly-taken picture to a text message.
Should be fixed with the dependency landed, so closing.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
blocking-b2g: 1.4? → 1.4+
I downloaded the tinderbox build with this in it and verified that this crash no longer occurs on my buri. (Mike's change missed the nightly build by 1 changeset).

Good work Mike!

Here is the link to the build I used: https://pvtbuilds.mozilla.org/pvt/mozilla.org/b2gotoro/tinderbox-builds/mozilla-central-hamachi-eng/20140220035628/
Status: RESOLVED → VERIFIED
Thanks Clint!

I've also tested this patch as it's landed, and can verify the fix on latest 1.4:

Gaia      35365feace970bfc51276428f40a477c9c86b7bb
Gecko     https://hg.mozilla.org/mozilla-central/rev/7010ab83a06e
BuildID   20140221040202
Version   30.0a1
ro.build.version.incremental=324
ro.build.date=Thu Dec 19 14:04:55 CST 2013
Duplicate of this bug: 970557
Target Milestone: --- → 1.4 S2 (28feb)
You need to log in before you can comment on or make changes to this bug.