Closed Bug 975184 Opened 6 years ago Closed 6 years ago

[B2G][Camera] Rocketbar does not pull down properly in the camera when accessed through the option to take a new photo for a contact

Categories

(Firefox OS Graveyard :: Gaia::Search, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v1.3 unaffected, b2g-v1.4 fixed, b2g-v2.0 unaffected, b2g-v2.1 unaffected)

RESOLVED WORKSFORME
Tracking Status
b2g-v1.3 --- unaffected
b2g-v1.4 --- fixed
b2g-v2.0 --- unaffected
b2g-v2.1 --- unaffected

People

(Reporter: rpribble, Unassigned)

References

Details

Description:
Navigating to the camera through the option to edit a contact and take a new photo for said contact results in the Rocketbar not pulling down or functioning properly. 'Contacts' disappears and nothing happens otherwise.

Repro Steps:
1) Updated buri to BuildID: 20140220040203
2) Tap contacts icon from home screen
3) Select a contact and tap it
4) Tap the edit contact button on the top right
5) Tap the photo to change contact photo
6)Tap the camera option
7) When camera has loaded, try to swipe down the 'Contacts' button with the magnifying glass from the upper left corner to access the Rocketbar
8) Observe 'Contacts' disappear

Actual:
Rocketbar does not function correctly when accessed through the camera while taking a new photo for a contact.

Expected:
All components work as expected.

Environmental Variables:
Device: buri v14 moz
BuildID: 20140220040203
Gaia: 6e71ab4da1b08586ea0c758edb7aa199ee34cd2f
Gecko: 660b62608951
Version: 30.0a1
RIL Version:
Firmware Version: Settings > Device Information > More Information > Firmware revision (example.D30008m)

Notes:

Repro frequency: 100%
Component: Gaia::Camera → Gaia::Search
I am not sure if this bug is valid anymore for 1.4?  I think it changed during the time of development.

Should we close this off as WFM?
Flags: needinfo?(rpribble)
Yep, no longer valid. User is no longer able to access the Rocketbar/E.me search bar while the camera is in use (following these repro steps).

v1.4 Environmental Variables:
Device: Buri v1.4 MOZ ril
BuildID: 20140718000231
Gaia: e0a732cf172d125eadfad59f0faf8f73b62012b8
Gecko: 074223c547af
Version: 30.0
Firmware Version: v1.2-device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

Notifications menu is pulled down as intended when user tries to swipe down while in the camera.
Flags: needinfo?(rpribble) → needinfo?(nhirata.bugzilla)
Thanks Rachel for verifying.
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(nhirata.bugzilla)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.