Closed Bug 975257 Opened 6 years ago Closed 4 years ago

[RTSP][V1.3] No warning message pops up after disabling network on the hotspot

Categories

(Firefox OS Graveyard :: RTSP, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(tracking-b2g:backlog, b2g-v2.1 affected)

RESOLVED WONTFIX
tracking-b2g backlog
Tracking Status
b2g-v2.1 --- affected

People

(Reporter: whsu, Assigned: ethan)

References

Details

(Whiteboard: [2.1-flame-test-run-1])

+++ This bug was initially created as a clone of Bug #951175 +++

* Description:
  This problem happened on v1.3 build.
  We fixed the crash issue (Bug 951175) but I think we need a warning message while FxOS cannot get video/audio streaming.

* Reproduction steps:
  1. Connect to a hotspot
  2. Launch the following page via browser
     - http://goo.gl/FyHFNs
  2. Tap the "Video test page"
  3. After FxOS launches the video to play RTSP stream, please disable the 3G network of hotspot but keep enabling the internet sharing.

* Expected result:
  FxOS pops up a warning message

* Actual result:
  No warning message pops up

* Reproduction build: V1.3 (Buri)
 - Gaia:     dca0a3dcf062ce3e422a9c56d141c14543c816fb
 - Gecko:    http://hg.mozilla.org/releases/mozilla-aurora/rev/1f7db4cc788e
 - BuildID   20131217004001
 - Version   28.0a2
Assignee: nobody → ettseng
nominate 1.4?
We should at least keep eyes on audio streaming case for 1.4.
Blocks: b2g-RTSP-2.0
No longer blocks: b2g-RTSP-1.3
blocking-b2g: --- → 1.4?
Whiteboard: [FT:RIL]
(In reply to Wesley Huang [:wesley_huang] from comment #1)
> nominate 1.4?
> We should at least keep eyes on audio streaming case for 1.4.
I think this is a minor bug. When it happens, there is no crash or system hanging. The user could still press the back or home button to exit the video app.
BTW, we added error handling for most common cases in bug 951188.
IMHO, I don't think this should be a blocker.
Component: General → Video/Audio
Product: Firefox OS → Core
Blocking 1.4 for RTSP audio issues
blocking-b2g: 1.4? → 1.4+
(In reply to Preeti Raghunath(:Preeti) from comment #3)
> Blocking 1.4 for RTSP audio issues

I'm in agreement with comment 2 here. This isn't a regression from 1.3 & is minor overall. This is not a blocker.
blocking-b2g: 1.4+ → backlog
Component: Video/Audio → RTSP
Product: Core → Firefox OS
Whiteboard: [FT:RIL]
Duplicate of this bug: 1005873
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
Whiteboard: [2.1-flame-test-run-1]
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]
blocking-b2g: backlog → ---
No one is actually working on RTSP for FxOS right now.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.