Closed Bug 975739 Opened 9 years ago Closed 9 years ago

[Flame]white screen of death occurs after H264 encoded video

Categories

(Firefox OS Graveyard :: Vendcom, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: nhirata, Unassigned)

Details

(Keywords: crash, Whiteboard: [POVB][b2g-crash])

STR needs refining :
1. play video using youtube app
2. play other applications

Expected: no crash
Actual: eventual white screen of death

Note:
1. all 3 seem to eventually crash with a white screen.

Gaia      147b93892a70bf6ebe723f57f6ad27acacb36ba4
Gecko     a082164c4237543ac749a114d7fea8c52651b902
BuildID   20140220131733
Version   28.0
ro.build.version.incremental=48
ro.build.date=Thu Feb 20 19:48:03 CST 2014
Flame
seems to work fine on Buri devices.  I think it might be a driver issue on the newer devices?
blocking-b2g: --- → 1.3?
Need to get logging and better STR
Flags: needinfo?(nhirata.bugzilla)
steps-wanted specifically on JB devices only
Component: Vendcom → General
Keywords: steps-wanted
Sora's white screen might be different.

It turns out that it may be a memory leak issue with a vendor chipset.
It also crashes w/ H264 encoded video.

We also need to test with webm content video to make sure it doesn't crash with that.
Flags: needinfo?(nhirata.bugzilla)
Summary: [Flame][Sora][Open C] white screen of death occurs after playing streaming video → [Flame][Sora][Open C] white screen of death occurs after H264 encoded video
Whiteboard: [FT:System-Platform]
Triage: waiting on clear STR.
Setting this to NI for John Hammink since we do not have a JB device here per Comment 3
Flags: needinfo?(jhammink)
Not possible to get logcat as STR involves using the Video app.

STR:
1.) Launch Video app; play a video encoded with H264.
2.) Launch FM radio; long tap home button, and go back to Video;
3.) Launch Music app; long tap home button and go back to video.
4.) Using task manager, alternately switch between applicaitons, and or return to homescreen.

I'm able to repro the issue repeating this cycle somewhat randomly more than 8 times.   Issue repeats 2/5 times.

Gaia      26e8a950f3ac703310ee8efcb741ff2418e9d190
Gecko     4ab635a5f5d2ff58cb33889f8f5e46a98f3170e3
BuildID   20140213175711
Version   28.0
ro.build.version.incremental=236
ro.build.date=Mon Feb 17 10:59:04 CST 2014
Flags: needinfo?(jhammink)
Keywords: steps-wanted
Anthony, can you help here?
blocking-b2g: 1.3? → 1.3+
Flags: needinfo?(ajones)
Whiteboard: [FT:System-Platform]
Dave - do you know a way to get a logcat for example by dumping to a file.  I need to get a logcat for this but cannot as STR involves using the video app.
Flags: needinfo?(dhylands)
I don't understand why the video app would have anything to do with logcat. USB Mass Storage would interfere, but not logcat.

Make sure USB Mass Storage is disabled.
Mke sure adb is enabled in the developer settings
Plug in your phone via USB
Start logcat: adb shell logcat > file
Do you video thing
Press Control-C to kill the logcat
Flags: needinfo?(dhylands)
I don't believe we can debug this on our side. adb completely dies when this happens.
(In reply to Michael Wu [:mwu] from comment #11)
> I don't believe we can debug this on our side. adb completely dies when this
> happens.

So who's help do we need then outside of Moz's side to debug this? QC?
Flags: needinfo?(ajones)
m1, any idea what's going on here? I think the hardware video decoder is crashing and taking down everything and adb, which I don't think gecko can do by itself.
Flags: needinfo?(mvines)
What AU are these devices all based on?
Flags: needinfo?(mvines)
(In reply to Michael Vines [:m1] [:evilmachines] from comment #14)
> What AU are these devices all based on?

The latest I think I've seen this on is AU240 on the Sora devices.
Sotaro mentioned offline that this is a vendor problem, so over to Vendcom.
blocking-b2g: 1.3+ → ---
Component: General → Vendcom
Whiteboard: [POVB]
(In reply to Michael Wu [:mwu] from comment #15)
> (In reply to Michael Vines [:m1] [:evilmachines] from comment #14)
> > What AU are these devices all based on?
> 
> The latest I think I've seen this on is AU240 on the Sora devices.

mvines - So you can find someone to investigate this then? We're going to fail YT certification if this does not get fixed.
Flags: needinfo?(mvines)
I need more build details. What's the full software release in use here?  The "AU" is just the apps code.
Flags: needinfo?(mvines)
v109-5

MSM8610.LF.1.0 CS
AMSS: r1030.1
Firefox OS v1.3
AU_LINUX_GECKO_B2G_JB_3.2.01.03.00.112.240

Is that enough? I don't think I have any more useful information unless there's something I can grab for you from getprop,
Thanks that helps.  Would be good to see this reproduce on AU_LINUX_GECKO_B2G_JB_3.2.01.03.00.112.255.  If it does, please provide the video from comment 7 if possible.
Not reproducible on our side(T2M), please help to provide the original H264 video file.
tested and verified on v107. v1.3 works well.
For comment 22, I cannot reproduce on my own H264 video, please help to provide the original H264 video file
Naoki - Can you check this again?
Flags: needinfo?(nhirata.bugzilla)
(In reply to Jason Smith [:jsmith] from comment #24)
> Naoki - Can you check this again?

Specifically - can you include the h264 video that's triggering this bug?
I am dropping off the sora/open c from the title until I can get a more reproducible situation for both those devices.

The base build used for the flame : 
Gaia      567608949aefd9f6da9d4c6c5bc9d0d3f8b6c402
Gecko     30a028c84f581e5ae6397141e82dde1fc6a6410f
BuildID   20140220211338
Version   28.0
ro.build.version.incremental=48
ro.build.date=Thu Feb 20 19:48:03 CST 2014

#busybox uname -r                                            
3.4.0-g3c7344d-00025-gd81f262

For the flame base build, I reproduce this issue.  It may have something to do with memory leak?  It's not just playing the video; it does seem to take a while to crash after playing.

To reproduce the issue, 
1. go to e.me, 
2. search youtube, 
3. launch youtube, 
4. search "full movies", 
5. select Underworld 1 Full Movie, 
6. play the video, 
7. set the device to full screen 
8. set device to landscape

Eventually it will white screen within 5 minutes.  Also I found that if it is plugged into a computer w/ USB, it will not white screen.
Summary: [Flame][Sora][Open C] white screen of death occurs after H264 encoded video → [Flame]white screen of death occurs after H264 encoded video
Flags: needinfo?(nhirata.bugzilla)
Well there goes my productivity. :)
I've been watching that clip for 25 minutes so far and going strong.  This is with the latest v1.3 full image on our reference device.
We now met several white screen cases in Flame.
It comes from modem crash and enter ramdump mode.
It's no surprise that adb not working in this status.
Here's the kernel log as below, but not sure if all the white screen cases are same root cause.

[   55.695461] SMSM: Modem SMSM state changed to SMSM_RESET.
[   55.701375] Fatal error on the modem.
[   55.704990] modem subsystem failure reason: wl1sleep.c:5586:AGC tune done for diversity timed out.
[   55.713981] Kernel panic - not syncing: subsys-restart: Resetting the SoC - modem crashed.
[   55.722216] [<c010ccb4>] (unwind_backtrace+0x0/0x138) from [<c08ad28c>] (panic+0x90/0x1f0)
[   55.730444] [<c08ad28c>] (panic+0x90/0x1f0) from [<c0165578>] (subsystem_restart_dev+0x90/0x1b4)
[   55.739207] [<c0165578>] (subsystem_restart_dev+0x90/0x1b4) from [<c0136f9c>] (modem_err_fatal_intr_handler+0x44/0x4c)
[   55.749884] [<c0136f9c>] (modem_err_fatal_intr_handler+0x44/0x4c) from [<c01f15dc>] (handle_irq_event_percpu+0x58/0x2b0)
[   55.760729] [<c01f15dc>] (handle_irq_event_percpu+0x58/0x2b0) from [<c01f1870>] (handle_irq_event+0x3c/0x5c)
[   55.770537] [<c01f1870>] (handle_irq_event+0x3c/0x5c) from [<c01f4124>] (handle_level_irq+0xac/0xfc)
[   55.779652] [<c01f4124>] (handle_level_irq+0xac/0xfc) from [<c01f0f98>] (generic_handle_irq+0x20/0x30)
[   55.788936] [<c01f0f98>] (generic_handle_irq+0x20/0x30) from [<c012d348>] (smp2p_gpio_in_notify+0x14c/0x2a0)
[   55.798746] [<c012d348>] (smp2p_gpio_in_notify+0x14c/0x2a0) from [<c08bc51c>] (notifier_call_chain+0x44/0x84)
[   55.808648] [<c08bc51c>] (notifier_call_chain+0x44/0x84) from [<c01aeddc>] (raw_notifier_call_chain+0x18/0x20)
[   55.818628] [<c01aeddc>] (raw_notifier_call_chain+0x18/0x20) from [<c012c360>] (smp2p_interrupt_handler+0x200/0x428)
[   55.829129] [<c012c360>] (smp2p_interrupt_handler+0x200/0x428) from [<c01f15dc>] (handle_irq_event_percpu+0x58/0x2b0)
[   55.839722] [<c01f15dc>] (handle_irq_event_percpu+0x58/0x2b0) from [<c01f1870>] (handle_irq_event+0x3c/0x5c)
[   55.849531] [<c01f1870>] (handle_irq_event+0x3c/0x5c) from [<c01f4560>] (handle_fasteoi_irq+0x98/0x160)
[   55.858905] [<c01f4560>] (handle_fasteoi_irq+0x98/0x160) from [<c01f0f98>] (generic_handle_irq+0x20/0x30)
[   55.868452] [<c01f0f98>] (generic_handle_irq+0x20/0x30) from [<c0106fbc>] (handle_IRQ+0x50/0xb8)
[   55.877216] [<c0106fbc>] (handle_IRQ+0x50/0xb8) from [<c0100414>] (gic_handle_irq+0x7c/0x124)
[   55.885729] [<c0100414>] (gic_handle_irq+0x7c/0x124) from [<c08ba9c0>] (__irq_svc+0x40/0x70)
one quick workaround to avoid the Flame modem crash in comment 28 is to turn on airplane mode.
it should help to clarify if there's any other root cause for white screen.
Hi Naoki,

Before turning on airplane mode, I hit white screen device hang easily no matter I watched Youtube or not. Even it is plugged into PC via USB (around 15-minute movie playing)

After turning on airplane mode, The movie "Underworld 1 Full Movie" on my Flame has been normally playing for more than one hour. 
Could you also test it at your side?
Flags: needinfo?(nhirata.bugzilla)
I turned on airport mode, turned on wifi and ran the video.  I still white screened.  Same build as stated in comment 26.

You have to be detached from a power source/computer.  Ie you cannot be plugged into any usb connection.
Also to note, my battery power was in the yellow when I ran this test.
Flags: needinfo?(nhirata.bugzilla)
Keywords: crash
Whiteboard: [POVB] → [POVB][b2g-crash]
Hi Naoki,

I followed the below steps which you comment above and still cannot repro this issue. 
1. Turn on airplane mode. 
2. Make power at the yellow state
3. Detached from any power resource/computers
4. Do the steps described in comment 26.
 
Also I cannot find the image you stated in comment 26. Could you use some newer images after 3/7 which I can find to test it again? 

The build I used: 
Gaia      e8bf7326ce5ed63bc8ef8b2cff1eba094887b9bf
Gecko     9dd67198a31d6e03c92fa6744653d25ffecf0dff
BuildID   20140307040055
Version   28.0
ro.build.version.incremental=eng.archermind.20140124.223316
ro.build.date=Fri Jan 24 22:34:04 CST 2014
Flags: needinfo?(nhirata.bugzilla)
Hi Blake.  I would need access to the newer image; based on what you are saying it may be fixed in the latest image.  Please provide us with a newer image.
Flags: needinfo?(nhirata.bugzilla) → needinfo?(bwu)
Hi Naoki,

You can use B2G-flash-tool to flash openC gecko/gaia image with the command, "auto_flash_from_twci.sh -w". 
or go to http://release1-qa.corp.tpe1.mozilla.com:8080/job/B2G.v1.3.0.openC/ with VPN access.
Flags: needinfo?(bwu)
Flags: needinfo?(nhirata.bugzilla)
Blake, the reason why you cannot find it is because I was using the OEM build as I believe this is an OEM issue.  I will test with the build for gecko/gaia that you have provided.
Flags: needinfo?(nhirata.bugzilla)
I am not sure if I have the right build?
- I cannot add smart collections, it will hang when trying to do so.
- I tried to do a search in e.me and it does not pull up any e.me web applications
- When adding the youtube page to the homescreen and trying to play from there, the movie does not play unless I place airplane mode on and turn on wifi.
- Same for playing the video in Browser.

I cannot add the youtube app from the e.me server in order to play the movie to reproduce the crash as commented in comment 26.
Crashing still occurs on the device, after playing for awhile.
It appears that the battery level has to be low (yellow)

Gaia      edde65421e811e9f923034529e6c31db9413e46b
Gecko     7553f99da1697e912e1d5198f5e13ef10fab646c
BuildID   20140314040055
Version   28.0
ro.build.version.incremental=48
ro.build.date=Thu Feb 20 19:48:03 CST 2014
Flame
To note, doesn't give a crash report [via Crash Reporter ( https://developer.mozilla.org/en-US/docs/Crash_reporting ) ] at all when this occurs.
Flags: needinfo?(bwu)
Hi Naoki,

It's strange that we got different result. Let's check if there is any difference missed. 
I put a video link to show how I reproed this bug. 
https://docs.google.com/a/mozilla.com/file/d/0B-iDmaXy16W2TVhUNzJYcXlBUmM/edit
Could you have a look and also show us yours with a recorded video?
Flags: needinfo?(bwu)
Flags: needinfo?(nhirata.bugzilla)
I just saw a new Flame OEM build that was released yesterday.  I will try to update with that and the Flame build you provided tomorrow.  I cannot access the VPN due to bug 985081  I will try to get you results tomorrow.
Looks like with the 109-2 gonk; I am not crashing at all with the H264
Flags: needinfo?(nhirata.bugzilla)
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
I am getting the white screen of death occurs when swtiching the videos when playing and also in youtube application this is happening with h/w decoder.  I am using ZTE OPEN C device and able to reproduce the issue all the the time. Using 1.3 pre-release image said for rooting the device also tried 1.4 firefox OS too. Can some tell me what is the exact fix done for the  white screen of death issue. Is it done on firefox side or the vendor library side. Can some one help me to solve the issue
(In reply to rakesh from comment #42)
> I am getting the white screen of death occurs when swtiching the videos when
> playing and also in youtube application this is happening with h/w decoder. 
> I am using ZTE OPEN C device and able to reproduce the issue all the the
> time. Using 1.3 pre-release image said for rooting the device also tried 1.4
> firefox OS too. Can some tell me what is the exact fix done for the  white
> screen of death issue. Is it done on firefox side or the vendor library
> side. Can some one help me to solve the issue

It should be a vendor problem.
Maybe you can try to update open C image here:
http://en.comebuy.com/developer-firefox-os-open-c.html
Thanks viral for the reply. I am already using Open C mentioned in the link.
Still I am getting the issue . I not even able to connect to adb the whole device goes to death state with white screen. I need to remove the battery and insert it again to recover from that state. Since I am not able to get the adb console I am not even able to check the logs to know what has went wrong
You need to log in before you can comment on or make changes to this bug.