Closed Bug 975824 Opened 6 years ago Closed 6 years ago

new Google Maps not displayed correctly

Categories

(Core :: Canvas: WebGL, defect)

x86_64
Windows 7
defect
Not set
major

Tracking

()

VERIFIED FIXED
mozilla30
Tracking Status
firefox29 --- unaffected
firefox30 + verified

People

(Reporter: c.ascheberg, Assigned: djg)

References

()

Details

(Keywords: regression)

Attachments

(4 files, 3 obsolete files)

Attached image screenshots
Open new Google Maps:
- map fades to black
- earth view missing graphics at the poles, earth looses all graphics when zooming out, stars are not displayed in the background

Happens with a new profile and in safemode.

Graphics
Adapter Description: NVIDIA GeForce 9600M GT
Adapter Drivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Adapter RAM: 512
Device ID: 0x0649
Direct2D Enabled: true
DirectWrite Enabled: true (6.2.9200.16571)
Driver Date: 2-29-2012
Driver Version: 8.17.12.9610
GPU #2 Active: false
GPU Accelerated Windows: 1/1 Direct3D 10
Vendor ID: 0x10de
WebGL Renderer: Google Inc. -- ANGLE (NVIDIA GeForce 9600M GT Direct3D9Ex vs_3_0 ps_3_0)
windowLayerManagerRemote: false
AzureCanvasBackend: direct2d
AzureContentBackend: direct2d
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated: 0

Regression:
Last good nightly: 2014-02-21
First bad nightly: 2014-02-22

Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=7010ab83a06e&tochange=84c9885475e7
Component: General → Graphics
Regression m-i
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=128cbf1edc40&tochange=673a7e313372

Suspect:
063362390b6e	Dan Glastonbury — Bug 966624 - Refactor Tex Image checks. r=jgilbert
Blocks: 966624
Component: Graphics → Canvas: WebGL
Huh. That's weird. No errors in the web console and all the conformance tests pass.
Assignee: nobody → dglastonbury
Status: NEW → ASSIGNED
Attached patch Fix compressed texture checks. (obsolete) — Splinter Review
Pretty glaring error in ValidateTexImageFormatAndType. Compressed texture types
weren't being checked and an error in the MOZ_ASSERT caused the error to return
without an message. Also, webgl_compressed_texture_s3tc.html is disabled in
mochitests, so the problem wasn't caught.
Attachment #8381246 - Flags: review?(jgilbert)
Attachment #8381246 - Flags: review?(vladimir)
Jeff is on PTO, so requesting Vlad to review.
Blocks: 948002
(In reply to Dan Glastonbury :djg :kamidphish from comment #2)
> Huh. That's weird. No errors in the web console and all the conformance
> tests pass.

Time to submit a new test case :)
Comment on attachment 8381246 [details] [diff] [review]
Fix compressed texture checks.

Please add a test.  If you can't reenable the existing disabled test (why is it disabled???), then please add a new targeted one testing this.
Comment on attachment 8381246 [details] [diff] [review]
Fix compressed texture checks.

Review of attachment 8381246 [details] [diff] [review]:
-----------------------------------------------------------------

Nits, but fine.

::: content/canvas/src/WebGLContextValidate.cpp
@@ +798,3 @@
>          }
>  
> +        if (level > 0) {

I would prefer `else if` here.

@@ +1199,5 @@
>      default:
>          // Only valid formats should be passed to the switch stmt.
> +        MOZ_ASSERT(false, "Unexpected format and type combo. How'd this happen?");
> +        // Fall through to return an InvalidOperations. This will alert us to the
> +        // unexpected case that needs fixing in builds without asserts.

Explicitly (albeit redundantly) set validCombo to false here, for clarity.
Attachment #8381246 - Flags: review?(jgilbert) → review+
Try run: https://tbpl.mozilla.org/?tree=Try&rev=e7453a55b532 (Something unrelated with java?!)
Jeff, the s3tc conformance test that would have caught this has a --min-version 1.0.2 in 00_test_list.txt. Do you know the reason for this? I ran both webgl-compressed-texture-s3tc.html and webgl-depth-texture.html fine on my OSX 10.9.
Flags: needinfo?(jgilbert)
(In reply to Dan Glastonbury :djg :kamidphish from comment #9)
> Jeff, the s3tc conformance test that would have caught this has a
> --min-version 1.0.2 in 00_test_list.txt. Do you know the reason for this? I
> ran both webgl-compressed-texture-s3tc.html and webgl-depth-texture.html
> fine on my OSX 10.9.

I think it's just because they're technically not part of the 1.0.1 suite, which is more or less what we run. We can special-case-enable it though. We still need to pull down the 1.0.2 (or newer) suite and triage those tests. I will likely be doing this in the next few weeks.
Flags: needinfo?(jgilbert)
Attachment #8381246 - Attachment is obsolete: true
Attachment #8381246 - Flags: review?(vladimir)
As requested for your review.
Attachment #8381719 - Flags: review?(jgilbert)
Comment on attachment 8381707 [details] [diff] [review]
Fix compressed texture checks.

Address nits from review.

Carry r=jgilbert.
Attachment #8381707 - Flags: review+
Comment on attachment 8381719 [details] [diff] [review]
Remove min-version from s3tc and depth conformance tests.

Interesting, the `---min-version` lines where we `-` `--min-version` don't play well with Splinter.
Attachment #8381719 - Flags: review?(jgilbert) → review+
Blocks: 976834
Backed out for webgl conformance test timeouts. Please run this through Try before requesting checkin again.
https://hg.mozilla.org/integration/mozilla-inbound/rev/52c0111e9852

https://tbpl.mozilla.org/php/getParsedLog.php?id=35279929&tree=Mozilla-Inbound
Even with this bug present, https://www.google.com/maps/@22.7615908,-102.5849904,14z works whereas https://www.google.com/maps/@22.7615908,-102.5849904,13z fails on Mozilla/5.0 (Windows NT 6.1; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0 ID:20140224030203 CSet: 31113754db3b

Is this a useful data point?
Weird. Let's only enable s3tc, and file a bug to get depth_texture.
Pre-emptively marking this verifyme as we'll want to test this once it's fixed.
Enable just the s3tc conformance test.
Attachment #8382611 - Flags: review?(jgilbert)
Attachment #8381719 - Attachment is obsolete: true
Attachment #8382611 - Flags: review?(jgilbert) → review+
Keywords: leave-open
(In reply to Dan Glastonbury :djg :kamidphish from comment #21)
> https://tbpl.mozilla.org/?tree=Try&rev=ff6f2f0eb414

Paul, can you please do some testing with this Try build overnight to check if this is fixed?
Flags: needinfo?(paul.silaghi)
(In reply to Anthony Hughes, QA Mentor (:ashughes) from comment #23)
> (In reply to Dan Glastonbury :djg :kamidphish from comment #21)
> > https://tbpl.mozilla.org/?tree=Try&rev=ff6f2f0eb414
> 
> Paul, can you please do some testing with this Try build overnight to check
> if this is fixed?
I downloaded the build from ftp://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/dglastonbury@mozilla.com-ff6f2f0eb414/try-win32/
Looks fixed, maps, earth view, street view, everything is ok on Win 7 x64.
I'll re-test when the nightly that includes the patch is available.
Flags: needinfo?(paul.silaghi)
extension incorrectly converted to .min from .html?!?
Attachment #8383474 - Flags: review?(jgilbert)
Attachment #8382611 - Attachment is obsolete: true
Try run with fixed 00_test_list.txt. Fails on VMware llvmpipe software GL.
https://tbpl.mozilla.org/?tree=Try&rev=9b7321e1da99
Disable s3tc/dxt texture compression on VMware + Gallium llvmpipe (used by try)
as it appears to be buggy.
Attachment #8383516 - Flags: review?(jgilbert)
Try run of just linux with disabled s3tc/dxt compressed textures.
https://tbpl.mozilla.org/?tree=Try&rev=a7d84785c17c
Attachment #8383474 - Flags: review?(jgilbert) → review+
Attachment #8383516 - Flags: review?(jgilbert) → review+
(In reply to Paul Silaghi, QA [:pauly] from comment #25)
> I downloaded the build from
> ftp://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/
> dglastonbury@mozilla.com-ff6f2f0eb414/try-win32/
> Looks fixed, maps, earth view, street view, everything is ok on Win 7 x64.
> I'll re-test when the nightly that includes the patch is available.
Verified fixed FF 30.0a1 (2014-03-02), Win 7, OSX 10.9, Ubuntu 13.04.
Left open per whiteboard.
Attachment #8383474 - Flags: checkin?(jgilbert)
Attachment #8383474 - Flags: checkin?(jgilbert) → checkin+
Attachment #8383516 - Flags: checkin+
https://hg.mozilla.org/mozilla-central/rev/7f2fade65d3a
https://hg.mozilla.org/mozilla-central/rev/870bb3450683
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla30
Status: RESOLVED → VERIFIED
Keywords: verifyme
No longer depends on: 995745
You need to log in before you can comment on or make changes to this bug.