Closed Bug 975937 Opened 6 years ago Closed 6 years ago

crash in mozilla::layers::ShaderProgramOGL::Activate()

Categories

(Core :: Graphics: Layers, defect, critical)

All
Android
defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla30

People

(Reporter: jchen, Assigned: mtseng)

References

Details

(Keywords: crash, regression, topcrash)

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is 
report bp-4a5f1f08-2573-4096-ab8f-339172140219.
=============================================================

This appears in the Android logcat right before the crash,

> === SHADER COMPILATION FAILED ===
> === Source:
> #ifdef GL_ES
> precision mediump float;
> #define COLOR_PRECISION lowp
> #else
> #define COLOR_PRECISION
> #endif
> varying vec2 vTexCoord;
> #extension GL_OES_EGL_image_external : require
> uniform samplerExternalOES uTexture;
> vec4 sample(vec2 coord) {
>   vec4 color;
>   color = texture2D(uTexture, coord);
>   return color;
> }
> void main() {
>   vec4 color = sample(vTexCoord);
>   COLOR_PRECISION float mask = 1.0;
>   color *= mask;
>   gl_FragColor = color;
> }
> 
> 
> === Log:
> 0:8: P0007: Extension directive must occur before any non-preprocessor tokens
> 0:9: L0001: Typename expected, found 'samplerExternalOES'
> ============

The crashes started with the 2014-02-19 nightly and are probably caused by bug 926128, considering that bug touched the shader program and was landed on 2014-02-18.
Flags: needinfo?(mtseng)
I saw similar issue resolve in bug 783754. According that bug, we should move all #entension macro to the top of shader code. I made a simple patch to move the #entension location. But I don't have any device that causes this issue. So I cannot confirm this patch fix this problem now.
Assignee: nobody → mtseng
Flags: needinfo?(mtseng)
Comment on attachment 8380456 [details] [diff] [review]
shader_complie_failed

Thanks for the patch! Seeing this is a top crash on Fennec and we don't have STR, let's take this speculative fix and look at the crash data afterwards.
Attachment #8380456 - Flags: review?(gal)
Comment on attachment 8380456 [details] [diff] [review]
shader_complie_failed

This will definitely fix the problem. Thanks for the quick work here Morris.
Attachment #8380456 - Flags: review?(gal) → review+
https://hg.mozilla.org/mozilla-central/rev/f6b60344ed5f
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla30
You need to log in before you can comment on or make changes to this bug.