Dragging a tab from one Browser window to an [e10s] Browser window breaks

VERIFIED FIXED in Firefox 30

Status

()

defect
VERIFIED FIXED
6 years ago
4 years ago

People

(Reporter: rcampbell, Assigned: billm)

Tracking

(Blocks 1 bug)

Trunk
Firefox 30
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

1. Open a "New e10s Window" (on mac, I guess)
2. Drag a tab from the original window to the new e10s window

expect:
tab moves from one to the other, document loads, etc.

actual:
new tab gets created with the right favicon but no document gets loaded in the e10s window. Original browser window keeps the tab in tab list, but it isn't selectable, has no document.
also have this on the Browser Console:

tabview assert: should already be linked
TabItems_update@chrome://browser/content/tabview.js:5661:7
TabItems_onMozAfterPaint@chrome://browser/content/tabview.js:5651:7
Presumably some exception getting thrown partway through the swap code?
I'm not sure what we really want to do here. We could keep the tab running in the chrome process, but that's probably not what the user wants. The only way to move it into the content process is to use session restore, but that causes potential data loss.

Also, the "New e10s window" thing is only for nightly. We're never going to ship it, so we shouldn't invest too much in it. But this is the second time someone has mentioned this bug. Maybe it's worth doing something.
I agree that it doesn't make a lot of sense to implement dragging tabs between e10s and non-e10s windows. I think the easiest thing to do is to just prevent dropping a tab there in the first place?
Yeah, for similar reasons, we don't allow moving tabs from a regular window to a private browsing window too. The drag&drop indicators simply don't show up as a target in the other window, so the user understands that no drop will occur. We should probably just do the same for the e10s window.

Of curse, we must take a look at what happens when dragging from one e10s window to another.. (on a separate bug). It could get complicated depending on how we partition the processes in the future. So this interaction is worth keeping in mind when thinking about that.
Posted patch tab-dragSplinter Review
OK, I guess that's pretty easy.
Assignee: nobody → wmccloskey
Status: NEW → ASSIGNED
Attachment #8383936 - Flags: review?(felipc)
Attachment #8383936 - Flags: review?(felipc) → review+
Duplicate of this bug: 972584
Component: Document Navigation → General
Product: Core → Firefox
Component: General → Tabbed Browser
OS: Mac OS X → All
Hardware: x86 → All
https://hg.mozilla.org/mozilla-central/rev/c5a7f033a90c
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 30
d&d tab to e10s from standar browser window just opens new standard browser window.
Status: RESOLVED → VERIFIED
Duplicate of this bug: 1094328
You need to log in before you can comment on or make changes to this bug.