Closed Bug 976738 Opened 6 years ago Closed 6 years ago

Devtools Themes - Switch back to light theme

Categories

(DevTools :: General, defect)

defect
Not set

Tracking

(firefox29 verified, firefox30 verified)

VERIFIED FIXED
Firefox 30
Tracking Status
firefox29 --- verified
firefox30 --- verified

People

(Reporter: harth, Assigned: harth)

References

Details

Attachments

(1 file)

There's some talk of switching back from the dark theme to the light theme as the default theme.
Previous discussion at Bug 966308
See Also: → 966308
I don't see enough comments in bug 966308 which are suggesting to switch it to light.

Also, if we finally agree on switching, we will have to uplift to Aurora again.
I nominate Darrin to make a decision.  I don't see how we can possibly make rational arguments one way or the other, so someone just has to decide what's best for the overall UX of our tools and Firefox as a whole.
Flags: needinfo?(dhenein)
I think light theme should be default. Users coming from any other browser will be used to a light theme, and probably more comfortable with the light theme. Users, who are used to the dark theme, will be able to seek out the dark theme. While I understand the theme might be a way to differentiate Firefox from other browser devtools, I think ultimately we should consider the ux implications of either themes. 

I hope the discussion regarding the topic of dark vs light colour theme on ux.stackexchange might bring some more insight https://ux.stackexchange.com/questions/8153/what-are-the-negative-and-positive-aspects-of-dark-color-scheme.
To quickly summarize some of the points, lighter themes are better for readability, and dark themes are preferred for handling visual content (images).
I think we should refrain ourselves from commenting further on this topic and let UX decide. Each user can comment on their beloved theme with various strong points and the discussion can keep on going without an end :)
I'm just going to leave this right here.
commit message: "No-one ever got fired for shipping a light theme."
@robcee lol

I hope not, because...

https://hg.mozilla.org/integration/fx-team/rev/8106dd48d2e8
Keywords: checkin-needed
Whiteboard: [fixed-in-fx-team]
(you should ask for aurora approval, but didn't hear this from me)
Comment on attachment 8391073 [details] [diff] [review]
Light theme as default

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined:
If declined, devtools users will see a new all-dark theme for one release, then an all-light theme the next release. This could be frustrating and annoying.

Testing completed (on m-c, etc.):
It is newly landed, but the light theme itself was the default for awhile before it was switched to dark in bug 966308. This is just a reversal of that patch.

Risk to taking this patch (and alternatives if risky):
Anything that theming could affect, like visual appearance. But this only affects the devtools. The theme has been in for awhile, this is just making it the default. Several people have been using this theme in the meantime.

String or IDL/UUID changes made by this patch:
None
Attachment #8391073 - Flags: approval-mozilla-aurora?
Flags: needinfo?(dhenein)
Like comment #7, I hope the same applies for approving such uplift. ;)
Anyway, I will approve it once it landed in m-c.
https://hg.mozilla.org/mozilla-central/rev/8106dd48d2e8
Assignee: nobody → fayearthur
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 30
Attachment #8391073 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Keywords: checkin-needed
Where was the decision to revert this made? Darrin didn't weight in on this.
(In reply to Stephen Horlander [:shorlander] from comment #14)
> Where was the decision to revert this made? Darrin didn't weight in on this.

Here is my last comment on the matter: https://bugzilla.mozilla.org/show_bug.cgi?id=966308#c9
Since UX didn't weight in on this at all, and apparently would not have agreed, I think it should be backed out instead of being slipped in at the last minute before uplift.
Flags: needinfo?(rcampbell)
Flags: needinfo?(dcamp)
(In reply to Stephen Horlander [:shorlander] from comment #16)
> Since UX didn't weight in on this at all, and apparently would not have
> agreed, I think it should be backed out instead of being slipped in at the
> last minute before uplift.

Discussion took place in our weekly meeting and in IRC on Friday.

Since this has been coming up for the duration of this cycle and we've been beating it to death, I r+'d the patch for approval and uplift.

Dark Theme users can still use the pref.
(In reply to Rob Campbell [:rc] (:robcee) from comment #17)
> (In reply to Stephen Horlander [:shorlander] from comment #16)
> > Since UX didn't weight in on this at all, and apparently would not have
> > agreed, I think it should be backed out instead of being slipped in at the
> > last minute before uplift.
> 
> Discussion took place in our weekly meeting and in IRC on Friday.
> 
> Since this has been coming up for the duration of this cycle and we've been
> beating it to death, I r+'d the patch for approval and uplift.

The discussion around which theme variant to ship has been lingering for a long time. Resulting in shipping a halfway state for a long while. It's not clear to me why rumblings about switching the default this cycle means it something that needs to be done. AFAIK no new information has come up on this topic.

More to the point I guess, my question is: Who owns this decision?

It seems like a design question and yet it is being changed without design input. More specifically, against standing design feedback.
Here's how we came to this. I'm not saying it's correct and really we have to defer to UX ultimately, but I want to convey the reasons we decided to go ahead with this change. If I'm missing anything, please comment in this bug. We can meet to discuss it next week.

We made a judgement call. I set the R+ flag based on our discussions.

We've received negative feedback about the dark theme. Feedback from users in the field, esteemed colleagues and peers. All of whom spend a lot of time staring at code. We know that there is a set of users who just don't like dark themes. Until now, the majority of our content area has been light. It's possible the improved contrast will mitigate some of these issues, but for some people, it doesn't matter.

On Visual Identity: I myself have used the "visual identity" claim to validate the dark theme. It makes us look different. But in the case where "looking different" turns a number of users away at first run, that identity could be counter-productive.

There's a pref. For people who really like the dark theme, they can turn it back on. We have some telemetry which suggests not a lot of people use the options panel. If it's too undiscoverable, we should fix that. We're getting to the point where a first run experience might be beneficial for users and Australis has paved the way for nice show & tell walkthroughs.

This change will coincide with Australis on all our channels. We're making a strong visual change that fits nicely with the rest of the browser.

And that's about the sum of my thinking on the R+.
Flags: needinfo?(rcampbell)
Status: RESOLVED → VERIFIED
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.