Closed Bug 966308 Opened 6 years ago Closed 6 years ago

DevTools Themes - Make dark theme the default

Categories

(DevTools :: General, defect)

defect
Not set

Tracking

(firefox29 verified, firefox30 verified)

VERIFIED FIXED
Firefox 30
Tracking Status
firefox29 --- verified
firefox30 --- verified

People

(Reporter: bgrins, Assigned: bgrins)

References

Details

Attachments

(2 files)

Attached image theme-ui-comparison.png
Now that the light theme toolbars are light, there is some question about it being a bit too drastic of a change as a default.  Attached is a (big) screenshot showing the old themes and new themes - notice that the top left (old light) is the current default that people see when they first open DevTools.

An assertion has been made that compared to the old light (top left), the new light (bottom left) is more jarring of a default than the new dark theme (bottom right), because the toolbars are different than before.

I don't feel strongly about it, though quite a few fans of the dark theme in #devtools do seem to.  We could set dark theme as a default and let the light theme bake for a while to reconsider later.
Anyway, here is a patch to switch the pref.  AFAIK we don't need to do anything else to make the change.
Comment on attachment 8368669 [details] [diff] [review]
theme-default.patch

Review of attachment 8368669 [details] [diff] [review]:
-----------------------------------------------------------------

Is this all that needs to be done?
Attachment #8368669 - Flags: review?(rcampbell)
The last time we had this discussion (a long time ago, in a galaxy far away, mostly for the Inspector tree, but that's all we had at the time) the conclusion was that dark themes are more annoying to the general majority of the population than light themes. Obviously, we used to have only one choice and no switching mechanism, but it still raises the question of "what does the majority want", and, last time we checked, the majority wanted light themed developer tools.

The dark theme looks epic (and I prefer it), but the light theme is more comfortable to the majority of users. I think we should stick to the decision we made a couple years ago and keep the light theme the default.
We did not have a white theme, a couple of years back to really compare.

And how do we know that majority of the devs get annoyed by the dark theme.

What I was suggesting on the channel was that let the light theme be default for now and lets see how the reaction is from aurora users [given that we get some reaction] and then decide on the default theme. Most users are used to dark theme, and a sudden change to "all bright" might not come as pleasant as we think.
Attachment #8368669 - Flags: review?(rcampbell) → review+
Have we reached a decision here?  There seem to be many people in each camp...  For my part, I think the Dark theme is great (especially for the toolbox chrome, etc.) as a nice differentiator from other browsers.
r+.

Ship It.
(In reply to J. Ryan Stinnett [:jryans] from comment #5)
> Have we reached a decision here?

UX said so.
Darrin, should we go ahead and switch over to the dark theme as a default?
Status: NEW → ASSIGNED
Flags: needinfo?(dhenein)
Not sure I feel fully qualified to make that call... I've only seen some anecdotal evidence from tweets/irc. There is no risk in continuing to default the dark theme and making this decision once we have some better information, as this seems like a pretty polarizing decision ;)
Flags: needinfo?(dhenein)
(In reply to Darrin Henein [:darrin] from comment #9)
> Not sure I feel fully qualified to make that call... I've only seen some
> anecdotal evidence from tweets/irc. There is no risk in continuing to
> default the dark theme and making this decision once we have some better
> information, as this seems like a pretty polarizing decision ;)

Fair enough, going to check this in
https://hg.mozilla.org/mozilla-central/rev/a1b47aeca0ce
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 30
This should be uplifted to Aurora, otherwise we will be confusing our users with switching themes twice!
Comment on attachment 8368669 [details] [diff] [review]
theme-default.patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 957117
User impact if declined: The default DevTools theme will be significantly different than in the previous release
Testing completed (on m-c, etc.): On m-c since 2/10
Risk to taking this patch (and alternatives if risky): No technical risk, the patch is just changing a default pref.  Non-technical risks include starting an argument about the best color scheme
String or IDL/UUID changes made by this patch:
Attachment #8368669 - Flags: approval-mozilla-aurora?
Attachment #8368669 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Depends on: 971418
Verified with latest builds of Nightly and Aurora
Status: RESOLVED → VERIFIED
Depends on: 976715
See Also: → 976738
Depends on: 980061
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.