Firebug stops working in Nightly30a1

RESOLVED INVALID

Status

()

defect
RESOLVED INVALID
5 years ago
2 years ago

People

(Reporter: alice0775, Unassigned)

Tracking

({regression})

30 Branch
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox29 unaffected, firefox30- affected)

Details

Reporter

Description

5 years ago
STR
1. Install https://addons.mozilla.org/en-US/firefox/addon/firebug/
   And restart

Actual Results:
No Firebug menu in tools > Web Developer
No Firebug icon in toolbar
Reporter

Comment 1

5 years ago
Regression window(fx)
Good:
https://hg.mozilla.org/integration/fx-team/rev/d7f05ca315a6
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0 ID:20140222195615
Bad:
https://hg.mozilla.org/integration/fx-team/rev/70df8261030a
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0 ID:20140222232915
Pushlog:
http://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=d7f05ca315a6&tochange=70df8261030a

Regressed by:
70df8261030a	Alexander J. Vincent — Bug 952307 - Move some addon-private JSM's to a subdirectory. r=Unfocused
Blocks: 952307
Keywords: regression
Reporter

Updated

5 years ago
Alex, Can you have a look at this since its related to your patch?
Flags: needinfo?(ajvincent)
http://code.google.com/p/fbug/issues/detail?id=7208

It looks like the Firebug developers are already aware of it and are planning a release with the fix.
Flags: needinfo?(ajvincent)
Though in fairness, we should find out why Firebug is depending on XPIProvider.jsm.  We moved it because it should be considered a private module.  It would be better for Firebug to not depend on it at all.

(I'm reminded of Linus Torvalds' "WE DO NOT BREAK USERSPACE" rant.  I get that this affects a lot of people, but I still believe we did the right thing here.)
(In reply to Alex Vincent [:WeirdAl] from comment #3)
> http://code.google.com/p/fbug/issues/detail?id=7208
> 
> It looks like the Firebug developers are already aware of it and are
> planning a release with the fix.
Yes, this will be fixed in Firebug 1.12.7

(In reply to Alex Vincent [:WeirdAl] from comment #4)
> Though in fairness, we should find out why Firebug is depending on
> XPIProvider.jsm.  We moved it because it should be considered a private
> module.  It would be better for Firebug to not depend on it at all.
Firebug needs to iterate bootstrapped scopes to properly initialize Firebug's
bootstrapped extensions.

XPIProviderBP.XPIProvider.bootstrapScopes

See also:

https://github.com/firebug/firebug/blob/firebug1.12/extension/modules/loader.js#L74

Is there any alternative how to do this?

Honza
Blair, I don't know how to answer the question in comment 5.
Flags: needinfo?(bmcbride)
(In reply to Jan Honza Odvarko from comment #5)
> Is there any alternative how to do this?

For getting at a bootstrap scope? No.

But if you can come up with a nice public API (in a new bug), we can implement something that's officially supported.
Flags: needinfo?(bmcbride)

Comment 8

2 years ago
This is about a legacy extension which is no longer valid in Firefox Quantum, closing.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.