Closed Bug 977347 Opened 7 years ago Closed 7 years ago

Unable to add a certain page to my bookmarks by using the star on the awesome bar

Categories

(Toolkit :: Places, defect)

27 Branch
x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 888567

People

(Reporter: dusty-2011, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 (Beta/Release)
Build ID: 20140212131424

Steps to reproduce:

Go to http://www.mozilla.org/en-US/firefox/28.0beta/releasenotes/. The first entry is Firefox for Windows 8 touch preview available (see blog post). Mouse middle click on the link "blog post", this should open https://blog.mozilla.org/futurereleases/2014/02/07/firefox-for-windows-8-touch-beta-is-ready-for-testing/ in a new tab. Now try to add the site to your bookmarks and put it in a certain folder by double clicking on the star in the awesome bar.


Actual results:

After the first mouse click the star briefly turns yellow and then goes back to its previous white color again. The site gets properly added to your bookmarks (in the unsorted bookmarks) but the star remains white (it should be yellow). After the second mouse click you should be presented with a menu which allows you to put the bookmark in a certain folder, this menu is not rendered.

After switching to a different tab and then back to the tab in question the star is properly displayed as yellow. The user can now click on the star again and put the bookmark in the desired folder.


Expected results:

The star should turn yellow on the first mouse click and stay yellow. On the second mouse click the user should see the menu which allows him to put the bookmark in a certain folder.


I should add that for testing purposes I have disabled all add-ons by running Firefox in safe mode. I can verify this bug in safe mode.
This is the only scenario in which adding a site to my bookmarks doesn't work properly, for all other sites it works properly.

There are other ways of adding this site to your bookmarks. I shall briefly discuss them below. [For verifying this bug always first open http://www.mozilla.org/en-US/firefox/28.0beta/releasenotes/ and then middle click on the link to open the site in question in a new tab.] 

Using Ctrl+D to add the site to my bookmarks works partially. The site gets properly added to my bookmarks but the star remains white (it should be yellow). Clicking on the star to change the folder I have put the bookmark in doesn't work. After switching tabs and then going back to the tab in question everything works properly (the star is yellow and clicking on it opens the menu).

Clicking on the bookmarks button on the right side of the navigation toolbar and then clicking on Bookmark This Page works similar to pressing Ctrl+D, i.e. it works partially as I described above.

I hope I have described the problem in sufficient detail, good luck with fixing it.
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Component: Untriaged → Places
Product: Firefox → Toolkit
Resolution: --- → DUPLICATE
Duplicate of bug: 888567
You need to log in before you can comment on or make changes to this bug.