Closed Bug 977399 Opened 7 years ago Closed 7 years ago

[B2G][Cost Control] 'Reset report' picker cannot be changed after data reset.

Categories

(Firefox OS Graveyard :: Gaia::Cost Control, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:1.3+, b2g-v1.2 unaffected, b2g-v1.3 fixed, b2g-v1.3T fixed, b2g-v1.4 fixed)

RESOLVED FIXED
1.4 S2 (28feb)
blocking-b2g 1.3+
Tracking Status
b2g-v1.2 --- unaffected
b2g-v1.3 --- fixed
b2g-v1.3T --- fixed
b2g-v1.4 --- fixed

People

(Reporter: pbylenga, Assigned: mai)

Details

(Keywords: regression)

Attachments

(2 files)

Description:
The 'Reset report' picker reel cannot be changed after a Data reset in Cost Control (Usage) app.  It'll stay on the selection that was chosen before the manual data reset.

Repro Steps:
1) Update a Buri to BuildID: 20140226004002
2) Launch Cost Control
3) Navigate to settings and note which option is chosen for "Reset report"
4) Reset Data for mobile & Wi-Fi
5) Attempt to change the option for "Reset report"

Actual:
After selecting a different option, nothing changes

Expected:
After selecting a different option, reel pickers update

v1.3 Environmental Variables:
Device: Buri v1.3 MOZ
BuildID: 20140226004002
Gaia: da50b2b62ed96993cf4df22e3d69c435b28506bd
Gecko: 3c39d1e487d9
Version: 28.0
Firmware Version: v1.2-device.cfg


Notes:

Repro frequency: 5/5, 100%
See attached: logcat
This issue does not occur on v1.2

v1.2 Environmental Variables:
Device: Buri v1.2 MOZ
BuildID: 20140220004002
Gaia: 539a25e1887b902b8b25038c547048e691bd97f6
Gecko: 2ea6a65eea23
Version: 26.0
Firmware Version: v1.2-device.cfg
blocking-b2g: --- → 1.3?
Assignee: nobody → mri
Attached file patch v1.0
Salva, could your review the patch?
Attachment #8382942 - Flags: review?(salva)
blocking-b2g: 1.3? → 1.3+
Not sure how useful this will be at this point given Comment 2, but here's the regression window.

Regression Window:

Last Working Environmental Variables:
Device: Buri
BuildID: 20140128004000
Gaia: 3c5119507a985c59cfc264ed23821679b138486d
Gecko: 4936f09590a0
Version: 28.0a2
Base Image: V1.2-device.cfg

First Broken Environmental Variables:
Device: Buri 
BuildID: 20140129004052
Gaia: b0aa74619cffb7a39ee0e7da5e9361a98e69f3f6
Gecko: 7d1173c4b173
Version: 28.0a2
Base Image: V1.2-device.cfg

Last Working Gaia/First Broken Gecko: Issue does NOT reproduce.
Gaia: 3c5119507a985c59cfc264ed23821679b138486d
Gecko: 7d1173c4b173

First Broken Gaia/Last Working Gecko: Issue DOES reproduce.
Gaia: b0aa74619cffb7a39ee0e7da5e9361a98e69f3f6
Gecko: 4936f09590a0

Gaia Pushlog: 
https://github.com/mozilla-b2g/gaia/compare/3c5119507a985c59cfc264ed23821679b138486d...b0aa74619cffb7a39ee0e7da5e9361a98e69f3f6
QA Contact: jzimbrick
Comment on attachment 8382942 [details] [review]
patch v1.0

Review my comments on GitHub and ask for my review again. Thank you.
Attachment #8382942 - Flags: review?(salva)
Comment on attachment 8382942 [details] [review]
patch v1.0

updated pr with your comments
Attachment #8382942 - Flags: review?(salva)
Comment on attachment 8382942 [details] [review]
patch v1.0

Working perfect. Thank you :mai!
Attachment #8382942 - Flags: review?(salva) → review+
Master: f69291e85f6792d76b3dcceca1b2b930be9e6508
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Please fill in the approval form:

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: 
Testing completed: 
Risk to taking this patch (and alternatives if risky): 
String or UUID changes made by this patch: none
Flags: needinfo?(mri)
Target Milestone: --- → 1.4 S2 (28feb)
Comment on attachment 8382942 [details] [review]
patch v1.0

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.
This patch fix a problem with the reset report picker on the settings page. 
[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): bug 928620
[User impact] if declined: The reset report picker does not work fine, when a data usage is refreshing on settings.
[Testing completed]: Yes
[Risk to taking this patch] (and alternatives if risky): Low risk
[String changes made]: No
Attachment #8382942 - Flags: approval-gaia-v1.3?(fabrice)
Flags: needinfo?(mri)
Attachment #8382942 - Flags: approval-gaia-v1.3?(fabrice) → approval-gaia-v1.3+
v1.3: d51d2e0963d9b761d5ea96243dfb13d9a220d521
You need to log in before you can comment on or make changes to this bug.