Closed Bug 977578 Opened 8 years ago Closed 8 years ago

preserveAspectRatio="none" not working as in other browsers

Categories

(Core :: SVG, defect)

27 Branch
x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 766956

People

(Reporter: david.dailey, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; Trident/7.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; HPDTDF; BRI/1; InfoPath.2; .NET4.0C; BRI/2; .NET4.0E; BOIE9;ENUSMSNIP; rv:11.0) like Gecko

Steps to reproduce:

http://cs.sru.edu/~ddailey/SwirlRoundNoAnim.svg


Actual results:

Other browsers (IE,Opera, Chrome) resize image to fit window. FF doesn't. Seems odd to me since I have other examples using preserveAspectRation=none that do work as I would expect in FF. 


Expected results:

The content should shrink or expand to fill the screen and should resize accordingly when the window is resized.
As you've done previously, you're missing a height="100%" on the root element.
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 766956
You need to log in before you can comment on or make changes to this bug.