Closed Bug 977862 Opened 6 years ago Closed 6 years ago

Customization mode outline doesn't appear on drag for empty toolbars

Categories

(Firefox :: Toolbars and Customization, defect)

All
Windows 8.1
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 30
Tracking Status
firefox29 --- verified
firefox30 --- verified

People

(Reporter: ntim, Assigned: Gijs)

References

Details

(Whiteboard: [Australis:P3-])

Attachments

(1 file)

Not sure if this is expected, but I noticed this with the new customization mode outlines.
I think this is expected as other browsers act the same way.
Right, I noticed this while implementing bug 963576 so instead used a custom attribute. Morphing this to cover 963576 comment 35:
(In reply to Tim Nguyen [:ntim] from comment #36)
> (In reply to Tim Nguyen [:ntim] from comment #35)
> > Unfortunatly, I can't see the outline on dragover (with an item grabbed).
> > But, I can see the outline on hover.
> 
> OS : Windows
Please specify the version. Is it 8.1 like in the OS field?

Possibly related to bug 977516
Assignee: nobody → MattN+bmo
Blocks: 963576
Flags: needinfo?(ntim007)
Summary: CSS hover element state is ignored on dragover → Customization mode outline doesn't appear on drag
Whiteboard: [Australis:P3-]
I use Win 8.1. 
Well, actually, I don't think it's related to the glass fog, since I get the problem on other toolbars too (bookmarks toolbar, addon toolbars). Btw, those outlines appear on hover fine. So it's probably due to the fact that the dragover event isn't triggered properly.
Flags: needinfo?(ntim007)
I'm seeing a similar issue on Windows 8.1 and Windows XP.

When moving the mouse over an empty part of the tab strip, I don't see an outline.
When moving the mouse over an icon in the tab strip (or the tabs themselves), the outline is there.
When dragging an icon to the tab strip, the outline is visible, regardless of the distinction above.

Tim, is this the same issue you are seeing or something else?
Flags: needinfo?(ntim007)
(In reply to Philipp Sackl [:phlsa] from comment #4)
> I'm seeing a similar issue on Windows 8.1 and Windows XP.
> 
> When moving the mouse over an empty part of the tab strip, I don't see an
> outline.
> When moving the mouse over an icon in the tab strip (or the tabs
> themselves), the outline is there.
> When dragging an icon to the tab strip, the outline is visible, regardless
> of the distinction above.
> 
> Tim, is this the same issue you are seeing or something else?

I do also have your issue, but the initial issue I reported is something else.
When you drag an item over any toolbar (bookmarks bar for example) or over the menu panel, the outline doesn't show up.

What's weird is that it shows up when you drag over the tabbar.
Flags: needinfo?(ntim007)
(In reply to Tim Nguyen [:ntim] from comment #5)
> (In reply to Philipp Sackl [:phlsa] from comment #4)
> > I'm seeing a similar issue on Windows 8.1 and Windows XP.
> > 
> > When moving the mouse over an empty part of the tab strip, I don't see an
> > outline.
> > When moving the mouse over an icon in the tab strip (or the tabs
> > themselves), the outline is there.
> > When dragging an icon to the tab strip, the outline is visible, regardless
> > of the distinction above.
> > 
> > Tim, is this the same issue you are seeing or something else?
> 
> I do also have your issue, but the initial issue I reported is something
> else.
Then I'll file a separate bug for this issue.

> When you drag an item over any toolbar (bookmarks bar for example) or over
> the menu panel, the outline doesn't show up.

That's weird, I can't reproduce this on my Windows 8 VM.
(In reply to Tim Nguyen [:ntim] from comment #5)
> (In reply to Philipp Sackl [:phlsa] from comment #4)
> > I'm seeing a similar issue on Windows 8.1 and Windows XP.
> > 
> > When moving the mouse over an empty part of the tab strip, I don't see an
> > outline.
> > When moving the mouse over an icon in the tab strip (or the tabs
> > themselves), the outline is there.
> > When dragging an icon to the tab strip, the outline is visible, regardless
> > of the distinction above.
> > 
> > Tim, is this the same issue you are seeing or something else?
> 
> I do also have your issue, but the initial issue I reported is something
> else.
> When you drag an item over any toolbar (bookmarks bar for example) or over
> the menu panel, the outline doesn't show up.
> 
> What's weird is that it shows up when you drag over the tabbar.

Can you reproduce this on a clean profile? Because I can't reproduce on win7 either... :-\
Actually, on a clean profile, I can't reproduce this issue, neither Philipp's issue.
(In reply to Tim Nguyen [:ntim] from comment #8)
> Actually, on a clean profile, I can't reproduce this issue, neither
> Philipp's issue.

It'd be interesting if we can figure out what's breaking this, then, if it's an add-on or some configuration of buttons / widgets on toolbars...
But, the menu panel has no outline even on a clean profile.

(In reply to :Gijs Kruitbosch from comment #9)
> (In reply to Tim Nguyen [:ntim] from comment #8)
> > Actually, on a clean profile, I can't reproduce this issue, neither
> > Philipp's issue.
> 
> It'd be interesting if we can figure out what's breaking this, then, if it's
> an add-on or some configuration of buttons / widgets on toolbars...
I'll try to investigate the issue.
Ok, found the issue, only empty toolbars are affected.
Summary: Customization mode outline doesn't appear on drag → Customization mode outline doesn't appear on drag for empty toolbars
Summary: Customization mode outline doesn't appear on drag for empty toolbars → Customization mode outline doesn't appear on drag for empty toolbars and menu panel
The menu panel isn't meant to have an outline - there's the single item outlines at the bottom of that area which should indicate that you can drag items there.
Assignee: MattN+bmo → gijskruitbosch+bugs
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Summary: Customization mode outline doesn't appear on drag for empty toolbars and menu panel → Customization mode outline doesn't appear on drag for empty toolbars
This does the trick for me
Attachment #8388211 - Flags: review?(mconley)
Comment on attachment 8388211 [details] [diff] [review]
dragging items onto an empty toolbar shows no drag outline,

Review of attachment 8388211 [details] [diff] [review]:
-----------------------------------------------------------------

This looks fine to me, and I tested that it fixes the problem on Windows 7.

Thanks Gijs!
Attachment #8388211 - Flags: review?(mconley) → review+
remote:   https://hg.mozilla.org/integration/fx-team/rev/1e331682951f
Whiteboard: [Australis:P3-] → [Australis:P3-][fixed-in-fx-team]
Comment on attachment 8388211 [details] [diff] [review]
dragging items onto an empty toolbar shows no drag outline,

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Australis
User impact if declined: empty bookmarks toolbar / additional toolbars won't have a drag outline
Testing completed (on m-c, etc.): soon on m-c
Risk to taking this patch (and alternatives if risky): very low
String or IDL/UUID changes made by this patch: none
Attachment #8388211 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/1e331682951f
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P3-][fixed-in-fx-team] → [Australis:P3-]
Target Milestone: --- → Firefox 30
Attachment #8388211 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.