Closed Bug 978012 Opened 7 years ago Closed 7 years ago

[email] Remove dead/obsolete GELAM-built JS blobs and fix GELAM to clean out ext/ before installing

Categories

(Firefox OS Graveyard :: Gaia::E-Mail, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
1.4 S2 (28feb)

People

(Reporter: asuth, Assigned: asuth)

Details

(Whiteboard: [p=0.5])

Attachments

(1 file)

While addressing bug 978005 (use "new" properly like a boss), I noticed my fixes weren't lining up with the manual transform from bug 976937.

It turns out we have two code zombies:
- apps/email/js/ext/mailapi/composer.js
- apps/email/js/ext/pop3.js

composer.js is my bad from bug 871897; the new blob is mailapi/drafts/composer.js because of some refactoring/moves I did.

It looks like pop3.js was a testing file or intermediary byproduct from development that accidentally got added in the initial commit.  I think I recall :mcav mentioning some hacky build attempts, which would explain some amusing gems in there:

  window.onerror = function (E) {
    dump("EEEEEEEEEEEEEEEEEEEEEEEEEEEE "+ E);
  }

  dump("SEETTING MOSFDJASEOIJEOIWFJWOEFJWIJEIWJ" + this.unprocessedLines[0]);


Anywho, I propose we make gelam rm -rf the 'ext' directory during the install-into-gaia step and then also check in the results.
readlink is different on OS X than linux, so this definitely needs to be run by someone.  (Although it's just "-f" that I think betrays you on OS X, -n should be fine.)

Please also sanity check that I'm right about the pop3.js file.

Thanks.
Attachment #8383566 - Flags: review?(m)
Comment on attachment 8383566 [details] [review]
gelam Makefile learns to nuke

Haha, silly debug messages. Yes, that looks like a mistake; hasn't been touched in 3 months by Gaia. I ran `make install-into-gaia` and it ran fine; I also ran the readlink-remove-ext command individually and confirmed that it properly wiped the files on OS X. Thanks for catching that!
Attachment #8383566 - Flags: review?(m) → review+
Whiteboard: [p=0.5]
You need to log in before you can comment on or make changes to this bug.