Closed Bug 978127 Opened 6 years ago Closed 6 years ago

Update various win8 specific australis customized ui tests to use new Services.metro.supported prop

Categories

(Firefox :: General, defect)

x86_64
Windows 8.1
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 30
Tracking Status
firefox29 --- fixed
firefox30 --- fixed

People

(Reporter: jimm, Assigned: jimm)

References

Details

Attachments

(1 file, 1 obsolete file)

And while we're here... I'm guessing this is related to bug 977954? Is Services.metro.supported true only on non-enable-metro builds?
Attached patch patchSplinter Review
easier than I expected. will push to try first.
See Also: → 977954
https://tbpl.mozilla.org/?tree=Try&showall=0&rev=1d404e015db3


(In reply to :Gijs Kruitbosch from comment #1)
> And while we're here... I'm guessing this is related to bug 977954? Is
> Services.metro.supported true only on non-enable-metro builds?

Yeah I can fix that too.
Blocks: 977954
Attached patch patch (obsolete) — Splinter Review
Attachment #8383761 - Attachment is obsolete: true
No longer blocks: 977954
Duplicate of this bug: 977954
That added ifdef isn't needed.
Attachment #8383766 - Attachment is obsolete: true
Attachment #8383761 - Attachment is obsolete: false
Comment on attachment 8383761 [details] [diff] [review]
patch

I'll land as soon as that try build comes back green.
Attachment #8383761 - Flags: review?(gijskruitbosch+bugs)
Comment on attachment 8383761 [details] [diff] [review]
patch

Review of attachment 8383761 [details] [diff] [review]:
-----------------------------------------------------------------

Sweet, thanks!
Attachment #8383761 - Flags: review?(gijskruitbosch+bugs) → review+
hmm, I got a failed test on linux browser-chrome - 

TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/customizableui/test/browser_890140_orphaned_placeholders.js | Should only be in default state if on Win8 - Got false, expected undefined
https://tbpl.mozilla.org/?tree=Try&showall=0&rev=ed2ad9708129

return Services.metro on linux resolved to 'undefined' in an is() test, but we compared it to false. Hopefully this comes up green.
https://hg.mozilla.org/mozilla-central/rev/a66831238267
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 30
Blocks: 969831
No longer depends on: 969831
Comment on attachment 8383761 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Disabling metro
User impact if declined: mochitest browser chrome perm orange failure will persist on mozilla-beta (See bug 990261)
Testing completed (on m-c, etc.): This is on m-c and aurora already which do not have a perm orange failure righ tnow.
Risk to taking this patch (and alternatives if risky): As close to none as possible the change is in a test. 
String or IDL/UUID changes made by this patch: none
Attachment #8383761 - Flags: approval-mozilla-beta?
Duplicate of this bug: 990261
Approval isn't needed for this. You can land this with a=tests
I'll get this in the morning if Brian doesn't beat me to it.
Whiteboard: [checkin-needed-beta]
Attachment #8383761 - Flags: approval-mozilla-beta?
Whiteboard: [checkin-needed-beta]
QA Whiteboard: [qa-]
You need to log in before you can comment on or make changes to this bug.