Closed Bug 978490 Opened 9 years ago Closed 9 years ago

[OMTC] Contents rapidly flickers

Categories

(Core :: Graphics: Layers, defect)

30 Branch
x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla30
Tracking Status
firefox29 --- unaffected
firefox30 --- fixed

People

(Reporter: alice0775, Assigned: mattwoodrow)

References

Details

(Keywords: regression)

Reported http://forums.mozillazine.org/viewtopic.php?p=13387811#p13387811

Steps To Reproduce:
1. Enable OMTC
   layers.offmainthreadcomposition.enabled = true
2. Restart Browser
3. Open https://people.mozilla.org/~shorlander/mockups-interactive/australis-interactive-mockups/windows8.html
4. Enter mockup's customize mode (Click mockup's Hamburger button and Customize button)

Actual Results:
Contents rapidly flickers 

Regression window(m-i)
Good:
https://hg.mozilla.org/integration/mozilla-inbound/rev/2d935f3e9587
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0 ID:20140220205527
Bad:
https://hg.mozilla.org/integration/mozilla-inbound/rev/e7349662e305
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0 ID:20140221003327
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=2d935f3e9587&tochange=e7349662e305

Suspect : Bug 973767


Graphics
--------

Adapter Description: ATI Radeon HD 4300/4500 Series
Adapter Drivers: aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64
Adapter RAM: 512
ClearType Parameters: Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 50
Device ID: 0x954f
Direct2D Enabled: true
DirectWrite Enabled: true (6.1.7601.18245)
Driver Date: 4-29-2013
Driver Version: 8.970.100.1100
GPU #2 Active: false
GPU Accelerated Windows: 1/1 Direct3D 11 (OMTC)
Vendor ID: 0x1002
WebGL Renderer: Google Inc. -- ANGLE (ATI Radeon HD 4300/4500 Series Direct3D9Ex vs_3_0 ps_3_0)
windowLayerManagerRemote: true
AzureCanvasBackend: direct2d
AzureContentBackend: direct2d
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated: 0
Local build,
Last Good: 2d935f3e9587
First Bad: 68b905ed5fc4
Regressed by:
  68b905ed5fc4	Robert O'Callahan — Bug 969354. Track which ThebesLayers contain items which returned true from ShouldFixToViewport, and make sure each such item gets its own ThebesLayer. r=mattwoodrow
Blocks: 969354
No longer blocks: 973767
I'm Windows-less here...
Assignee: nobody → matt.woodrow
Because it isn't Direct3D 11 compaitable, it's the Radeon 4000 series fault. Firefox is now using Direct3D 11 and Direct2D. Using process explorer, It apparently requires Direct3D 11 and below Radeon 5000 is Direct3D 10/10.1 or lower. I'd get rid of the card due to this, because Direct2d doesn't work right on anything older then Direct3D 11. AMD also has marked this card legacy and stopped updates on it.
Except the issue was also reported to occur on nVidia Geforce GTX 760 (source: http://forums.mozillazine.org/viewtopic.php?p=13388081#p13388081), so your analysis does not seem to hold water.

But it seems to have been fixed now, as I can't seem to reproduce this anymore on my end.
I swear I was getting similar flickering on at least one of my machines.

(In reply to Nick from comment #3)
> Because it isn't Direct3D 11 compaitable, it's the Radeon 4000 series fault.
> Firefox is now using Direct3D 11 and Direct2D. Using process explorer, It
> apparently requires Direct3D 11 and below Radeon 5000 is Direct3D 10/10.1 or
> lower. I'd get rid of the card due to this, because Direct2d doesn't work
> right on anything older then Direct3D 11. AMD also has marked this card
> legacy and stopped updates on it.

If it's not D3D11 compatible, and we're trying to run D3D11 on it, that's our fault.
We still have both D3D9 and software compositing backends which we're supporting, so if anything, we should hold onto this card as long as possible, if it's being problematic.
I can not reproduce on bad build of comment#0 as well as Latest Nightly(2014-03-19)...

So, I think the site changed something.
Thanks!
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Depends on: 981393
Target Milestone: --- → mozilla30
QA Whiteboard: [good first verify]
You need to log in before you can comment on or make changes to this bug.