Closed Bug 978876 Opened 6 years ago Closed 6 years ago

Support declined engines in meta/global on desktop

Categories

(Firefox :: Sync, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla30
Tracking Status
firefox28 --- wontfix
firefox29 + fixed
firefox30 + fixed

People

(Reporter: rnewman, Assigned: rnewman)

References

(Blocks 1 open bug)

Details

(Keywords: dev-doc-complete, Whiteboard: [qa+])

Attachments

(2 files)

Forking the non-UI bits of Bug 969669.
Component: Sync → Firefox Sync: Backend
Product: Firefox → Mozilla Services
Version: 29 Branch → unspecified
Greg, you already reviewed some of this, I think, but another skim won't hurt.
Attachment #8385876 - Flags: review?(gps)
Should be trivial.
Attachment #8385878 - Flags: review?(gps)
This should be tracking 29; it's forked from Bug 969669 (which should now track 30), and parallels Bug 969672 (which tracks Fennec 29).

Needs to land with the first public release of Sync 1.5, else clients without it will fail to update or preserve the correct metadata, ultimately leading to incorrect prompting. (And it's a protocol change, and those should all land before the protocol escapes into the wild.)
Can you give a more specific example of the impact of this bug, from a user perspective? Not sure what you mean by "incorrect prompting", how likely that is to occur, in which scenarios, etc.
Your first bug number is this bug.

Re the second: it would allow us to turn that situation into a detectible (and recoverable) failure, with or without user involvement.

Incorrect prompting: if we ship this bug in anything later than 29 (and we're already going to do this to current Nightly and Aurora users), we will at some future point (30 or 31) show a big doorhanger telling them that they could be syncing some things that they're not currently syncing, even though they explicitly chose not to sync those things.

Furthermore, we would have to do additional work to not keep screwing up like that (i.e., asking them again every time their meta/global changes) if they continue to sync with Firefox 29, because 29 wouldn't be following the spec.


Honestly, I'm going to ask for Aurora or Beta approval to land this change regardless, and expect it to be given in order to address other work items.

There's no value in tracking *for me*, so feel free to track or not according to whether there's value in it for you.
Ping, gps? I'm hoping to land this week.
Attachment #8385876 - Flags: review?(gps) → review+
Attachment #8385878 - Flags: review?(gps) → review+
Comment on attachment 8385876 [details] [diff] [review]
Part 1: handle declined engines in desktop Sync meta/global.

(Request for all four parts.)

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
  Old Sync protocol omissions.

User impact if declined: 
  Future Firefox releases will have difficulty correctly responding to client errors around datatype selection, differences in capabilities between clients, and future engine additions. Declining this uplift will also result in post-GA protocol churn, which is generally undesirable.

Testing completed (on m-c, etc.): 
  Been baking for a day or two. Manually tested. Unit-tested.

Risk to taking this patch (and alternatives if risky): 
  Should be slim. Failures are likely to be limited to errors in recording of declined engines themselves, which is a risk I consider acceptable.

String or IDL/UUID changes made by this patch:
  None.
Attachment #8385876 - Flags: approval-mozilla-aurora?
Flags: needinfo?(rnewman)
Attachment #8385876 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Blocks: 444284
Component: Firefox Sync: Backend → Sync
Product: Cloud Services → Firefox
You need to log in before you can comment on or make changes to this bug.