Closed Bug 979026 Opened 8 years ago Closed 8 years ago

[Messages] SMS app Checkerboards while scrolling

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:1.4+)

RESOLVED WORKSFORME
1.4 S4 (28mar)
blocking-b2g 1.4+

People

(Reporter: mchang, Assigned: mchang)

References

Details

(Keywords: perf, Whiteboard: [c=handeye p=4 s= u=1.4])

Attachments

(5 files)

Profile - https://people.mozilla.org/~bgirard/cleopatra/#report=28c3f9f7d854d63d2ee93e743ecf2cd5405cb4ff. We see that we also spend a bunch of time in pgralloc, having ~20-40ms grallocs.

This is with patches from bug 977680, bug 979018, and bug 972731. It's much harder to checkerboard a full screen anymore, but it still happens here and there.
The latest development of tiling on our graphics branch improve gralloc/buffer rotation bounds testcase a great deal.
Depends on: 972731
Duplicate of this bug: 986687
blocking-b2g: --- → 1.4?
blocking-b2g: 1.4? → 1.4+
Whiteboard: [c=handeye p=4 s= u=] → [c=handeye p=4 s= u=1.4]
Target Milestone: 1.4 S3 (14mar) → ---
Just tested on master, here's a profile up - https://people.mozilla.org/~bgirard/cleopatra/#report=0b06da00a84de76614defd4930ae351431fd7a78. The recent improvements to tiling have helped a lot.

We no longer checkerboard the SMS app with a reference workload light. Closing as WFM. The only time left spent while scrolling is in BrowserElementPanning.js - bugs 976605 and bug 970125 should fix this.
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
We have to be careful here.  Bug 986687 was tested on QRD, with the latest tiling and other graphics improvements.  If we're tagging it as a duplicate of this bug, than this probably isn't a work for me.  Or the other one isn't a duplicate.
I tested on today's master with a hamachi device and scrolled as fast as I could. If you do a casual scroll as if I was actually reading my SMS, I couldn't checkerboard.
(In reply to Mason Chang [:mchang] from comment #3)
> Just tested on master, here's a profile up -
> https://people.mozilla.org/~bgirard/cleopatra/
> #report=0b06da00a84de76614defd4930ae351431fd7a78. The recent improvements to
> tiling have helped a lot.
> 
> We no longer checkerboard the SMS app with a reference workload light.
> Closing as WFM. The only time left spent while scrolling is in
> BrowserElementPanning.js - bugs 976605 and bug 970125 should fix this.

Per QC's testing in the dupe, this isn't working right now. You need test this with the heavy workload to reproduce this problem right now.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Attached file SMS Layer Tree
Thanks Mason for recording this.  I can see this is Buri/Hamachi - probably the phone you have access to, so it's great.  I don't know how QC was testing, but I know that in the past we ran into checkerboarding quickest when scrolling fast in one direction, then reversing the direction of the scroll, also going fast, and repeating. Basically, something to mess up the heuristic :)
We see 1 checkerboard with the normal scroll and 1 slight blip with the really fast scroll. But it's not very perceivable. 

Profile w/ a checkerboard - https://people.mozilla.org/~bgirard/cleopatra/#report=ec7afe69a5b5e30a20d8c6f6eb99d57d8cdeefb5

In range 8441 - 9206, we see a fairly long rasterize - 200 ms + a 100ms buildDisplayList.
Per Mason's videos in comment 8, comment 9, and comment 12 checkerboarding during SMS scrolling is no longer an issue. Closing as WFM.
Status: REOPENED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → WORKSFORME
Target Milestone: --- → 1.4 S4 (28mar)
Attached file Display List Dump
In case we have to come back to this.
Tapas/Vikram - can you guys please take a look again and see if the issue we raised in bug 986687 is fixed now?
Flags: needinfo?(tkundu)
Flags: needinfo?(mvikram)
We'll verify it in a build early next week.
Flags: needinfo?(mvikram)
Thanks Vikram. Keeping the ni as a reminder.
Flags: needinfo?(mvikram)
On the latest build (04/01), the checkerboarding is not observed. This issue can be considered as resolved.
Flags: needinfo?(mvikram)
Flags: needinfo?(tkundu)
You need to log in before you can comment on or make changes to this bug.