Closed Bug 979197 Opened 6 years ago Closed 2 years ago

[OPEN C_1.3] How to disable the options releated to internal memory?

Categories

(Firefox OS Graveyard :: Vendcom, defect, major)

ARM
Linux
defect
Not set
major

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: chen.cong, Unassigned)

Details

(Whiteboard: [POVB])

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E; CIBA; Tablet PC 2.0; TCO_20140304170526)

Steps to reproduce:

1) Add volume.cfg file to /system/etc/ directory;
2) Without insert SD card, the phone can use internal memory to take picture;
 


Actual results:

Functions like exporting contacts to SD Card are available. Our understanding is that this is wrong, as there is not any external SD Card inserted. In this case, options related to memory card should be disabled.


Expected results:

Functions Options releated to internal memory  like exporting contacts to SD Card can be disable.
Severity: normal → major
blocking-b2g: --- → 1.3?
OS: All → Linux
Hardware: All → ARM
QC RIL commit:
a406d321  Add null check when handling set preferred network type
QC RIL TAG version: AU_LINUX_GECKO_B2G_JB_3.2.01.03.00.112.223

gaia commit:
744fb691 Merge pull request #15526 from steveck-chung/bug-961231

gecko commit:
6840e8c2 Bumping gaia.json for 1 gaia-1_3 revision(s) a=gaia-bump
What's the behavior that is seen by the user when you try to export contacts without a sdcard?
Keywords: qawanted
Without SD Card, user can use the internal memory to take picture and export contacts. Because the internal memory is not a SD Card, so the contact data can't move to other phones. So the test engineer from aurigae company and tid company think functions like exporting contacts to SD Card should be disable without SD Card.
(In reply to chencong from comment #3)
> Without SD Card, user can use the internal memory to take picture and export
> contacts. Because the internal memory is not a SD Card, so the contact data
> can't move to other phones. So the test engineer from aurigae company and
> tid company think functions like exporting contacts to SD Card should be
> disable without SD Card.

Was this modified in your build though in a custom way? To my understanding, you can't take pictures in the camera app without a sdcard on our builds.

What is this volume.cfg change being made here?
Keywords: qawanted
Whiteboard: [POVB]
Vendor bug.
blocking-b2g: 1.3? → ---
Component: Gaia::Contacts → Vendcom
We didn't make any of assumption about how many storages should be in devices now.
And we treat the same behaviour if there's only one storage included.

Since you already know openC will include one internal storage and one external sdcard (optional), you can modify the code in gaia to check if there's 2nd storage to have different behaviours with/without external storage.
Firefox OS is not being worked on
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.