Closed Bug 979199 Opened 6 years ago Closed 6 years ago

DataStore should not dispatch events when the window is destroyed

Categories

(Core :: DOM: Core & HTML, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla30
blocking-b2g 1.3+
Tracking Status
firefox28 --- wontfix
firefox29 --- wontfix
firefox30 --- fixed
b2g-v1.3 --- fixed
b2g-v1.3T --- fixed
b2g-v1.4 --- fixed

People

(Reporter: baku, Assigned: baku)

References

Details

Attachments

(1 file)

Depends on: 976311
OS: Linux → All
Hardware: x86_64 → All
Attached patch patchSplinter Review
Attachment #8385185 - Flags: review?(ehsan)
Comment on attachment 8385185 [details] [diff] [review]
patch

Can you please add a test for this?
Attachment #8385185 - Flags: review?(ehsan) → review+
I cannot because it's a timing issue.
https://hg.mozilla.org/mozilla-central/rev/ab74cf1deced
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla30
Blocks: 985042
baku and I discussed this on IRC and taking this allows us to more cleanly fix bug 985042 => 1.3+.
blocking-b2g: --- → 1.3+
Comment on attachment 8385185 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: DataStore will try to read data from a dead window.
Risk to taking this patch (and alternatives if risky): none
Attachment #8385185 - Flags: approval-mozilla-b2g28?
Attachment #8385185 - Flags: approval-mozilla-b2g28? → approval-mozilla-b2g28+
I wonder if we need bug 976311 on b2g28 as well. Try will say!
https://tbpl.mozilla.org/?tree=Try&rev=7ffa2d9b27cf
Yup, that was the problem.
Flags: needinfo?(amarchesini)
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.