bing pc and form codes are incorrect

VERIFIED FIXED in Firefox 28

Status

defect
P1
normal
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: mconnor, Assigned: mconnor)

Tracking

unspecified
Firefox 30
x86_64
Windows 8
Dependency tree / graph

Firefox Tracking Flags

(firefox28 verified, firefox29 verified, firefox30 verified, b2g-v1.3 fixed)

Details

(Whiteboard: p=0 s=it-30c-29a-28b.3 r=ff30 [qa+])

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
Bug 917933 got this wrong.  I'm guessing some excellent levels of telephone game at work here.  That said, we have a table for these things now, so I'm going to get this updated.

Partner code should be MOZW and the form code should be MOZWSB.  I'm adding a different branding pref to match what we're doing for Yahoo in bug 942024 and switching the Bing plugin to use that pref instead.
Attachment #8385426 - Flags: review?(mbrubeck)
Attachment #8385426 - Flags: review?(mbrubeck) → review+
Blocks: metrobacklog
Whiteboard: [triage]
(Assignee)

Comment 1

5 years ago
Comment on attachment 8385426 [details] [diff] [review]
implement distinct Metro codes

https://hg.mozilla.org/integration/mozilla-inbound/rev/bcc3e9304304

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: impact to revenue/measurement only
Testing completed (on m-c, etc.): tested locally.
Risk to taking this patch (and alternatives if risky): minitmal, only impacts metro partner codes, incorrect configuration will not impair functionality.
String or IDL/UUID changes made by this patch: none
Attachment #8385426 - Flags: approval-mozilla-beta?
Attachment #8385426 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/bcc3e9304304
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 30
QA Contact: kamiljoz
Whiteboard: [triage] → p=0 s=it-30c-29a-28b.3 r=ff30
Whiteboard: p=0 s=it-30c-29a-28b.3 r=ff30 → p=0 s=it-30c-29a-28b.3 r=ff30 [qa+]
Attachment #8385426 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+

Updated

5 years ago
Blocks: 917933
Attachment #8385426 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
For testing and verification.  Reopen if any defects found.
Flags: needinfo?(kamiljoz)
Went through verification using the following builds:
- http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014-03-09-03-02-04-mozilla-central/
- http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014-03-09-00-40-03-mozilla-aurora/
- http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/28.0b9/win32/en-US/

- Ensured that the form search code appears as "MOZSBR" under fxdesktop (Nightly, Aurora, BETA)
- Ensured that the form search code appears as "MOZWSB" under fxmetro (Nightly, Aurora, BETA)
- Ensured that the "MOZW" partner ID is being used under fxmetro (BETA)
- Ensured that the "MOZI" partner ID is being used under fxdesktop (BETA)
Status: RESOLVED → VERIFIED
Flags: needinfo?(kamiljoz)
You need to log in before you can comment on or make changes to this bug.