Closed Bug 979456 Opened 6 years ago Closed 6 years ago

Australis: Extra padding exists at the left edge of the Bookmarks toolbar

Categories

(Firefox :: Toolbars and Customization, defect)

30 Branch
x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 30
Tracking Status
firefox29 --- fixed
firefox30 - fixed

People

(Reporter: alice0775, Assigned: Gijs)

References

(Blocks 1 open bug)

Details

(Keywords: regression, Whiteboard: [Australis:P3])

Attachments

(2 files)

Steps To Reproduce:
1. Enable Bookmarks Toolbar
2. Look leftmost bookmark

Actual Results:
Extra padding exists at the left edge of the bookmark toolbar

Actual Results:
No extra padding


Regression window(fx)
Good:
https://hg.mozilla.org/integration/fx-team/rev/ae231333480e
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0 ID:20140228085430
Bad:
https://hg.mozilla.org/integration/fx-team/rev/7a80f82f5ce5
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0 ID:20140228090533
Pushlog:
http://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=ae231333480e&tochange=7a80f82f5ce5

Regressed by:
7a80f82f5ce5	Mike Conley — Bug 942600 - [Australis] Bookmarks toolbar items can get suddenly overflowed when dragging items into it. r=mak.
Attached image screenshot
And I notice ugly behavior.

When I drag a link over toolbar, the extra padding disappears. and all bookmark buttons shift to the left.....
Whiteboard: [Australis:P3]
Duplicate of this bug: 979276
Looking.
Assignee: nobody → gijskruitbosch+bugs
This fixes things, AFAICT. What do you think? :-)
Attachment #8386135 - Flags: review?(mconley)
Attachment #8386135 - Flags: review?(mconley) → review+
Whiteboard: [Australis:P3] → [Australis:P3][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/f02aa38ed27e
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P3][fixed-in-fx-team] → [Australis:P3]
Target Milestone: --- → Firefox 30
Attachment #8386135 - Flags: approval-mozilla-aurora+
QA Whiteboard: [qa-]
You need to log in before you can comment on or make changes to this bug.