Multiple assertions - view unread, sort by thread

VERIFIED DUPLICATE of bug 90990

Status

MailNews Core
Database
VERIFIED DUPLICATE of bug 90990
17 years ago
10 years ago

People

(Reporter: Phil Anderton, Assigned: Scott MacGregor)

Tracking

({assertion})

Trunk
x86
Windows 2000
assertion

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Opening a newsgroup causes multiple occurrences of the following assertion:

###!!! ASSERTION: couldn't get header for some reason: 'NS_SUCCEEDED(rv) && msgH
dr', file e:\moz_src\mozilla\mailnews\base\src\nsMsgThreadedDBView.cpp, line 300

Settings are:

View / Messages / Unread, Threaded
View / Sortby / Thread, Ascending

It seems like one assertion per thread.

Updated

17 years ago
QA Contact: esther → laurel
(Reporter)

Comment 1

17 years ago
The problem seems to be that nsMsgThread::InitCachedValues() is setting
m_numUnreadChildren to a non-zero value (the same value as m_numChildren), but
in nsMsgThread::GetFirstUnreadChild it turns out that all children are in fact read.
Component: Mail Back End → Mail Database
(Reporter)

Updated

17 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Updated

17 years ago
Keywords: assertion

Comment 2

17 years ago

*** This bug has been marked as a duplicate of 90990 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 3

17 years ago
verified as duplicate
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.