navigation in menus crashes if use gtk-qt-engine themes

RESOLVED DUPLICATE of bug 1062145

Status

defect
RESOLVED DUPLICATE of bug 1062145
5 years ago
5 years ago

People

(Reporter: zefilipe.groups, Unassigned)

Tracking

Details

Attachments

(4 attachments)

Reporter

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:27.0) Gecko/20100101 Firefox/27.0 (Beta/Release)
Build ID: 20140203105208

Steps to reproduce:

In KDE 4.11 i enter in systemsettings -> aplication appearance -> gtk+ appearance
If i change the widget style to one of gtk-qt-engine themes like all murrina or oxygen-gtk, and click apply when i acess instantbird contacts windows, and access to menus its crashes and shows the window to report bug and restart instantbird

But if use for example Clearlooks, it dont crash !


Actual results:

AbortMessage: [25501] ###!!! ABORT: X_CreatePixmap: BadAlloc (insufficient resources for operation); 4 requests ago: file /builds/slave/linux/build/mozilla/toolkit/xre/nsX11ErrorHandler.cpp, line 157
Add-ons: vertical-tabs%40patrick.cloke:0.5,sort-by-status%40patrick.cloke:0.1pre,smile%40mic.instantbird.org:1.2,messagestyle-bubbles-light%40instantbird.org:2.4,messagestyle-ambiance%40addons.instantbird.org:1.8.1,emoticons-skype-smileys%40instantbird.org:1.0.10,%7B972ce4c6-7e08-4474-a285-3208198ce6fd%7D:1.6a1pre,emoticons-kolobok%40addons.instantbird.org:1.2
BuildID: 20140303041310
CrashTime: 1394118935
EMCheckCompatibility: true
Email: zefilipe.groups@gmail.com
FramePoisonBase: 00000000f0dea000
FramePoisonSize: 4096
InstallTime: 1394098669
Notes: OpenGL: Intel Open Source Technology Center -- Mesa DRI Intel(R) Q35  -- 2.1 Mesa 9.2.4 -- texture_from_pixmap
X_CreatePixmap: BadAlloc (insufficient resources for operation); 4 requests agoxpcom_runtime_abort([25501] ###!!! ABORT: X_CreatePixmap: BadAlloc (insufficient resources for operation); 4 requests ago: file /builds/slave/linux/build/mozilla/toolkit/xre/nsX11ErrorHandler.cpp, line 157)
ProductID: {33cb9019-c295-46dd-be21-8c4936574bee}
ProductName: Instantbird
ReleaseChannel: nightly
SecondsSinceLastCrash: 17931
StartupTime: 1394101194
Theme: classic/1.0
Throttleable: 1
Vendor: Instantbird
Version: 1.6a1pre
useragent_locale: en-US

This report also contains technical information about the state of the application when it crashed.


Expected results:

The theme Clearlooks is not very fun using kde, but using oxygen-gtk its more unified !
It is very good if this bug will be fixed ;-)
Reporter

Comment 1

5 years ago
Screenshot when i change gtk+ appearance to oxygen-gtk, one of the gtk-qt-engine themes
Reporter

Comment 2

5 years ago
In this screenshot, its applyed oxygen-gtk, when i access any menus it crashes and shows the instantbird bug reporter with the options quit or restart
Reporter

Comment 3

5 years ago
After i access any meny its shows the instantbird bug reporter like this
Reporter

Comment 4

5 years ago
im using Fedora 19, KDE 4.11.5, QT 4.8.5, Kernel 3.12.11
Do you have a crash report link? You can check this in /about crashes and give us the hash. Also, please update to a newer nightly and ensure this is still an issue. There have been a lot of changes since your nightly.
Reporter

Comment 6

5 years ago
Posted image intantbird about
Reporter

Comment 7

5 years ago
Hi !

I think that you need to see my instantbird about, right ?
That is there
https://bug980340.bugzilla.mozilla.org/attachment.cgi?id=8387489

I've the last beta ersion, with the nightly updates active, every time that it has a nightly update, its updates my instantbird automaticaly !

Regards
Reporter

Comment 8

5 years ago
In one nightly update so a times ago it had be stable and this bug is partialy fixed, but now after many updates this bug continues ... !

Comment 9

5 years ago
See bug 1062145 for a workaround for this problem.
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1062145
You need to log in before you can comment on or make changes to this bug.