Crash when opening contextual menus on Linux x64

RESOLVED DUPLICATE of bug 985986

Status

RESOLVED DUPLICATE of bug 985986
4 years ago
3 years ago

People

(Reporter: mozilla, Unassigned)

Tracking

trunk
x86_64
Linux

Details

(Whiteboard: [1.6-wanted], URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:32.0) Gecko/20100101 Firefox/32.0
Build ID: 20140830210550

Steps to reproduce:

I installed Instantbird (latest nightly but this bug is there since a long time, I just didn't found the moment to file this bug).
Then I open Ib, I right click in any window anywhere or I open one of the menu un the menubar (like File / Tools or Help)


Actual results:

Instantbird crash. The only messages in console are the following :

(process:2867): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed
[2867] ###!!! ABORT: X_CreatePixmap: BadAlloc (insufficient resources for operation); 4 requests ago: file /home/buildbot/buildslave/linux64/build/mozilla/toolkit/xre/nsX11ErrorHandler.cpp, line 157
[2867] ###!!! ABORT: X_CreatePixmap: BadAlloc (insufficient resources for operation); 4 requests ago: file /home/buildbot/buildslave/linux64/build/mozilla/toolkit/xre/nsX11ErrorHandler.cpp, line 157



Expected results:

Menu should have opened :).
(Reporter)

Updated

4 years ago
OS: All → Linux
Hardware: All → x86_64

Comment 1

4 years ago
I can confirm this happens on KDE. Completely breaks IB.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [1.6-blocking]

Comment 2

4 years ago
Created attachment 8526684 [details]
snapshot.png

Intermittently, the menu actually appears, but is transparent (see screenshot).

This may be some initialization issue: I once got as far as getting IB to display menus properly (not sure why or how). It was then stable.

Updated

4 years ago
Depends on: 985986

Comment 3

4 years ago
This is an issue with the default gtk engine KDE uses for gtk apps, gtk2-engines-oxygen. As a workaround, switching the gtk theme may work (in KDE system settings). 

What definitely works is to create a symlink calld "komodo" or "seamonkey" (or one of the other XUL apps KDE is aware of) which links to the "instantbird" executable, and starting Instantbird via this symlink.

Updated

4 years ago
Duplicate of this bug: 980340

Comment 6

4 years ago
Thanks, finaly solved an bug very waited for so mutch time ;-)
I had experimented and now works well, and the themes for KDE and GTK are mostly uniform, unless had very different themes ;-)
Regards

Comment 7

4 years ago
Nothing we can really do here for now, and it has a workaround, so reducing to 1.6-wanted.
Whiteboard: [1.6-blocking] → [1.6-wanted]

Comment 8

3 years ago
Fixed upstream for oxygen-gtk 1.4.
http://quickgit.kde.org/?p=oxygen-gtk.git&a=commit&h=b1ee5fb80c44c6c8a625333af1cfdc997d408805
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED

Updated

3 years ago
Resolution: FIXED → DUPLICATE
Duplicate of bug: 985986
You need to log in before you can comment on or make changes to this bug.