Closed Bug 980582 Opened 6 years ago Closed 6 years ago

[e10s] Linux + Hardware Acceleration + WebGL Error spew: "isCrossProcess, but not MOZ_WIDGET_GONK! Someone needs to write some code!"

Categories

(Core :: Graphics: Layers, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla31

People

(Reporter: johns, Assigned: evilpie)

References

()

Details

Attachments

(1 file, 1 obsolete file)

Blocks: 893304
It's true! This is sort of Layers, as opposed to actual WebGL, though.
OS: Linux → All
Hardware: x86_64 → All
Component: Canvas: WebGL → Graphics: Layers
Attached patch fix (obsolete) — Splinter Review
This is probably not what we want to ship with, but at least it works.
Attachment #8395797 - Flags: review?(jgilbert)
Attachment #8395797 - Flags: review?(jgilbert) → review?(jmuizelaar)
Assignee: nobody → evilpies
Comment on attachment 8395797 [details] [diff] [review]
fix

Okay I going to look into this some more.
Attachment #8395797 - Flags: review?(jmuizelaar)
Duplicate of this bug: 989696
Duplicate of this bug: 991164
Attached patch otherSplinter Review
I think this is good enough for a crash fix.
Attachment #8395797 - Attachment is obsolete: true
Attachment #8400766 - Flags: review?(jmuizelaar)
Comment on attachment 8400766 [details] [diff] [review]
other

Review of attachment 8400766 [details] [diff] [review]:
-----------------------------------------------------------------

::: gfx/layers/client/CanvasClient.cpp
@@ +37,5 @@
>                                   TextureFlags aFlags)
>  {
> +#ifndef MOZ_WIDGET_GONK
> +  if (XRE_GetProcessType() != GeckoProcessType_Default) {
> +    // Fixme: Most platforms still need an optimized way to share GL cross process.

NS_Warning or something like that? Also, I thought this might regress OS X where we already use IOSurfaces to share surfaces, but it looks like WebGL is still broken.
Attachment #8400766 - Flags: review?(jmuizelaar) → review+
(In reply to Marc Auslander from comment #9)
> Fixes bug: https://bugzilla.mozilla.org/show_bug.cgi?id=991164
> 
> Thanks

I am actually kind of curious on why that is. Just enabling OMTC would still have everything in the same process, so the code shouldn't be hit at all.
Since I may have done a previous experiment poorly - I have enabled both 

layers.offmainthreadcomposition.enabled and
layers.offmainthreadcomposition.testing.enabled

although I believe only the former was needed to trigger bug 91164.

In any case, it's not failing for me right now.
https://hg.mozilla.org/mozilla-central/rev/9b8036ab4f81
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla31
This fixes bug 991164.  Thanks.
Blocks: 994969
You need to log in before you can comment on or make changes to this bug.