Blinking caret in panel text

VERIFIED FIXED in Firefox 30

Status

defect
P2
normal
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: willmarquardt, Assigned: zer0)

Tracking

unspecified
mozilla31

Firefox Tracking Flags

(firefox30 verified, firefox31 verified, b2g-v1.4 fixed)

Details

Attachments

(2 attachments)

Reporter

Description

5 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:27.0) Gecko/20100101 Firefox/27.0 (Beta/Release)
Build ID: 20140212131424

Steps to reproduce:

Created a panel with a span, a div, and an unordered list with list items. Then clicked on each.


Actual results:

Blinking cursors appeared wherever I clicked. 


Expected results:

Nothing.

I tested the same HTML page in a tab and no cursors appeared.
Priority: -- → P2

Comment 1

5 years ago
Can confirm this not very nice right now. The problem is also reported here on the forum https://forums.mozilla.org/addons/viewtopic.php?f=27&t=15678&hilit=caret
An example of this problem can be seen if you install https://addons.mozilla.org/en-US/firefox/addon/heartbleed_monitor/, open the panel, and click near the "Settings" checkboxes.

Comment 3

5 years ago
Thanks Garrett, now its even easier for the developers to reproduce this problem. Same problem on OS X.
Duplicate of this bug: 920807
Posted file pull/1464
It seems the behavior was introduced adding the `showcaret` attribute.
Not sure why it was added; Irakli do you recall anything about that?
It seems that text inputs have caret even without this attribute.
Attachment #8407702 - Flags: review?(rFobic)
Attachment #8407702 - Flags: review?(rFobic) → review+

Comment 6

5 years ago
Commits pushed to master at https://github.com/mozilla/addon-sdk

https://github.com/mozilla/addon-sdk/commit/7e1e003219d18011df237b472d18ad21cd42344c
Bug 980714 - Blinking caret in panel text

- removed `showcaret` attribute

https://github.com/mozilla/addon-sdk/commit/922dafe37147a8ae537b1c8b68352d15ad2c8784
Merge pull request #1464 from ZER0/panel-caret/980714

fix Bug 980714 - Blinking caret in panel text r=@gozala

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Can we get this uplifted to aurora and beta? It is the cause of frequent complaints in our addon which uses the SDK panel (https://github.com/EFForg/privacybadgerfirefox).
Flags: needinfo?(rFobic)
(In reply to Garrett Robinson [:grobinson] from comment #7)
> Can we get this uplifted to aurora and beta? It is the cause of frequent
> complaints in our addon which uses the SDK panel
> (https://github.com/EFForg/privacybadgerfirefox).

We're working on uplift patches, I plan to ask that this be uplifted to 30 & 31 ( you can test the fix in the current nightly build: http://nightly.mozilla.org/ )
Posted patch patch.diffSplinter Review
[Approval Request Comment]
Bug caused by (feature/regressing bug #): panel refactoring
User impact if declined: users will see the blinking caret on the panel's content, even if the content is not editable.
Testing completed (on m-c, etc.): m-c, m-a, locally 
Risk to taking this patch (and alternatives if risky): very low risk, we just removed the "showcaret" attribute. 
String or IDL/UUID changes made by this patch: none
Attachment #8426253 - Flags: approval-mozilla-beta?
Aurora seems have already the patch applied, see: http://mxr.mozilla.org/mozilla-aurora/source/addon-sdk/source/lib/sdk/panel/utils.js#223
Flags: needinfo?(rFobic)
This landed in github in the 31 cycle, per comment 6, so I assume it made it to trunk in 31 as well.
Target Milestone: --- → mozilla31
(In reply to Matteo Ferretti [:matteo] [:zer0] from comment #9)
> [Approval Request Comment]
> Bug caused by (feature/regressing bug #): panel refactoring

When did this land? Is 29 or earlier affected?
Attachment #8426253 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Zero - can you answer Gavin's questions?

Gavin: I think this only affects 29.
Flags: needinfo?(zer0)

Comment 14

5 years ago
I think this was at least in FF 28 too probably even earlier but not sure.
(In reply to :Gavin Sharp (email gavin@gavinsharp.com) from comment #12)
> (In reply to Matteo Ferretti [:matteo] [:zer0] from comment #9)
> > [Approval Request Comment]
> > Bug caused by (feature/regressing bug #): panel refactoring
> 
> When did this land? Is 29 or earlier affected?

Yes, 29 and 28 are definitely affected. If our tags in github are correct, it's probably a bug we have since the panel refactoring, that it seems happened in Firefox 23.
Flags: needinfo?(zer0)
Reproduced the initial issue on old Nightly (2014-03-06), verified using Heartbleed Monitor add-on on Firefox 30 beta 7 and latest Aurora on Windows 7 64bit, Mac OS X 10.9.2 and Ubuntu 14.04 32bit.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.