Closed Bug 980978 Opened 7 years ago Closed 7 years ago

Ensure perf event listener is up before sending perf events...

Categories

(Firefox OS Graveyard :: Gaia::PerformanceTest, defect, P1)

x86_64
Linux
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 846909
1.4 S6 (25apr)

People

(Reporter: hub, Assigned: hub)

References

Details

(Keywords: perf, Whiteboard: [c=automation p=2 s= u=])

Lately, perf event test have been failing more with a timeout because the even got sent before the listener was up.

We should fix that.

First we should fix the timeout detection from bug 980972
Depends on: 980972
Bug 846909 should be able to help.
Keywords: perf
Whiteboard: [c=automation p= s= u=]
Blocks: 837669
Priority: -- → P1
Yep it's bug 846909. I want this ! :)

It would also make the numbers a lot more reliable, because currently the 'time start point' varies a lot.
(In reply to Julien Wajsberg [:julienw] from comment #2)
> Yep it's bug 846909. I want this ! :)

I'll dupe this on it if that really fixes it :-)
Assignee: nobody → hub
Status: NEW → ASSIGNED
Whiteboard: [c=automation p= s= u=] → [c=automation p=2 s= u=]
confirming dupe.
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 846909
No longer blocks: 837669
Target Milestone: --- → 1.4 S6 (25apr)
You need to log in before you can comment on or make changes to this bug.