Closed Bug 980972 Opened 7 years ago Closed 7 years ago

Detect marionette script timeout

Categories

(Firefox OS Graveyard :: Gaia::PerformanceTest, defect, P1)

x86_64
Linux
defect

Tracking

(b2g-v1.3T fixed)

RESOLVED FIXED
1.4 S5 (11apr)
Tracking Status
b2g-v1.3T --- fixed

People

(Reporter: hub, Assigned: hub)

References

Details

(Keywords: perf, Whiteboard: [c=automation p=1 s= u=])

Attachments

(1 file)

We should detect marionette timeout.

Like in the

 performanceHelper.observe();
 performanceHelper.waitForPerfEvent();

pattern.

This could help us track regressions in the testing.
Keywords: perf
Whiteboard: [c=automation p= s= u=]
Blocks: 980978
Bug 981009 must be fixed first.
Depends on: 981009
No longer depends on: 981009
Assignee: nobody → hub
Status: NEW → ASSIGNED
Depends on: 981009
No longer depends on: 981009
(In reply to Hubert Figuiere [:hub] from comment #1)
> Bug 981009 must be fixed first.

Not really.
Priority: -- → P1
Whiteboard: [c=automation p= s= u=] → [c=automation p=1 s= u=]
Hey Hubert, I won't be able to review this before my holidays. So either this will wait until 24th March, or you'll need to find another reviewer.
Comment on attachment 8389377 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/17092

James, do you think you can review this?
Attachment #8389377 - Flags: review?(felash) → review?(jlal)
Summary: Detect marionette timeout → Detect marionette script timeout
Comment on attachment 8389377 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/17092

Julien, do you mind since you are back from PTO?

Thanks.
Attachment #8389377 - Flags: review?(jlal) → review?(felash)
Comment on attachment 8389377 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/17092

comments on github

thanks!
Attachment #8389377 - Flags: review?(felash)
Comment on attachment 8389377 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/17092

Updated the PR.
Attachment #8389377 - Flags: review?(felash)
Comment on attachment 8389377 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/17092

r=me except if you want to do the comment about the "done" function, in that case I'd like another review please :)
Attachment #8389377 - Flags: review?(felash) → review+
I got hit by an unrelated intermittent Travis error. All green now.

Merged
https://github.com/mozilla-b2g/gaia/commit/fb0aec1ef13f915a9739fc889df88ceda07c7b53
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.4 S5 (11apr)
You need to log in before you can comment on or make changes to this bug.