[HELP WANTED] [malloc] memory allocation problems - DOM

RESOLVED WONTFIX

Status

()

Core
DOM: Core & HTML
P3
normal
RESOLVED WONTFIX
19 years ago
18 years ago

People

(Reporter: chris hofmann, Assigned: vidur (gone))

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
check bug 8227 for more details on what need to be done to this code.

s:/mozilla/dom/tools/IdlParser.cpp
   Deref-error: "enumObj", line 367
   Deref-error: "enumerator", line 382
   Deref-error: "enumerator", line 383
   Deref-error: "enumObj", line 384
   Deref-error: "enumerator", line 398
   Deref-error: "constObj", line 455
   Deref-error: "constObj", line 458
   Deref-error: "constObj", line 461
   Deref-error: "constObj", line 464
   Deref-error: "constObj", line 467
   Deref-error: "constObj", line 470
   Deref-error: "constObj", line 473
   Deref-error: "constObj", line 476
   Deref-error: "constObj", line 479
   Deref-error: "constObj", line 482
   Deref-error: "constObj", line 486
   Deref-error: "constObj", line 491
   Deref-error: "constObj", line 492
   Deref-error: "constObj", line 505
   Deref-error: "constObj", line 529
   Deref-error: "constObj", line 532
   Deref-error: "attrObj", line 588
   Deref-error: "attrObj", line 589
   Deref-error: "attrObj", line 597
   Deref-error: "attrObj", line 600
   Deref-error: "attrObj", line 603
   Deref-error: "attrObj", line 606
   Deref-error: "attrObj", line 609
   Deref-error: "attrObj", line 612
   Deref-error: "attrObj", line 615
   Deref-error: "attrObj", line 618
   Deref-error: "attrObj", line 621
   Deref-error: "attrObj", line 624
   Deref-error: "attrObj", line 628
   Deref-error: "attrObj", line 631
   Deref-error: "attrObj", line 636
   Deref-error: "attrObj", line 637
   Deref-error: "attrObj", line 643
   Deref-error: "attrObj", line 644
   Deref-error: "attrObj", line 657
   Deref-error: "funcObj", line 680
   Deref-error: "funcObj", line 686
   Deref-error: "funcObj", line 689
   Deref-error: "funcObj", line 692
   Deref-error: "funcObj", line 695
   Deref-error: "funcObj", line 698
   Deref-error: "funcObj", line 701
   Deref-error: "funcObj", line 704
   Deref-error: "funcObj", line 707
   Deref-error: "funcObj", line 710
   Deref-error: "funcObj", line 713
   Deref-error: "funcObj", line 717
   Deref-error: "funcObj", line 720
   Deref-error: "funcObj", line 723
   Deref-error: "funcObj", line 728
   Deref-error: "funcObj", line 735
   Deref-error: "funcObj", line 750
   Deref-error: "funcObj", line 781
   Deref-error: "funcObj", line 788
   Deref-error: "funcObj", line 809
   Deref-error: "funcObj", line 835
   Deref-error: "funcObj", line 852
   Deref-error: "argObj", line 895
   Deref-error: "argObj", line 904
   Deref-error: "argObj", line 906
   Deref-error: "argObj", line 911
   Deref-error: "argObj", line 913
   Deref-error: "argObj", line 918
   Deref-error: "argObj", line 920
   Deref-error: "argObj", line 935
   Deref-error: "argObj", line 938
   Deref-error: "argObj", line 941
   Deref-error: "argObj", line 944
   Deref-error: "argObj", line 947
   Deref-error: "argObj", line 950
   Deref-error: "argObj", line 953
   Deref-error: "argObj", line 956
   Deref-error: "argObj", line 959
   Deref-error: "argObj", line 962
   Deref-error: "argObj", line 966
   Deref-error: "argObj", line 969
   Deref-error: "argObj", line 974
   Deref-error: "argObj", line 975
   Deref-error: "argObj", line 981
   Deref-error: "argObj", line 982
   Deref-error: "argObj", line 988
   Deref-error: "argObj", line 989
   Deref-error: "argObj", line 1002
s:/mozilla/dom/tools/main.cpp
   Deref-error: "parser", line 117
   Deref-error: "specification", line 131
   Deref-error: "xpcomgen", line 139
   Deref-error: "jsgen", line 156
(Reporter)

Updated

19 years ago
Blocks: 8227
Summary: [malloc] memory allocation problems - DOM → [HELP WANTED] [malloc] memory allocation problems - DOM
Target Milestone: M15
Not for beta, I don't think.
*** Bug 10443 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WONTFIX
(Assignee)

Comment 3

18 years ago
dom/tools contains the source to idlc which will go away after 5.0. It works,
it's not part of the actualy product, it doesn't need to be fixed.
You need to log in before you can comment on or make changes to this bug.