Closed Bug 982835 Opened 6 years ago Closed 6 years ago

[OSX] Bookmark item hover background color is wrong when subview opened in Panel UI

Categories

(Firefox :: Theme, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 30
Tracking Status
firefox29 --- fixed
firefox30 --- fixed

People

(Reporter: Gijs, Assigned: Gijs)

References

(Blocks 1 open bug)

Details

(Keywords: regression, Whiteboard: [Australis:P3])

Attachments

(1 file)

This is because https://hg.mozilla.org/mozilla-central/rev/ccbe695b5f40#l6.12 made the toolbarbutton.bookmark-item rules more specific by adding :not(#bookmarks-menu-button), which means it now beats the .subviewbutton rule and so the toolbar hover style is applying instead of the panel one.
Summary: Bookmarks hover background color is wrong when in Panel UI → [OSX] Bookmark item hover background color is wrong when subview opened in Panel UI
Blocks: 963098
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Comment on attachment 8390452 [details] [diff] [review]
Australis bookmark subview hover color is wrong when in main menu panel,

Review of attachment 8390452 [details] [diff] [review]:
-----------------------------------------------------------------

I like it! Thanks for fixing this.
Attachment #8390452 - Flags: review?(mdeboer) → review+
remote:   https://hg.mozilla.org/integration/fx-team/rev/6213d1669c1a
Whiteboard: [Australis:P3] → [Australis:P3][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/6213d1669c1a
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P3][fixed-in-fx-team] → [Australis:P3]
Target Milestone: --- → Firefox 30
Comment on attachment 8390452 [details] [diff] [review]
Australis bookmark subview hover color is wrong when in main menu panel,

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Australis / bug 909349
User impact if declined: bookmark items in the menu have the wrong hover color
Testing completed (on m-c, etc.): on m-c
Risk to taking this patch (and alternatives if risky): very low
String or IDL/UUID changes made by this patch: none
Attachment #8390452 - Flags: approval-mozilla-aurora?
Attachment #8390452 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Depends on: 985958
QA Whiteboard: [qa-]
You need to log in before you can comment on or make changes to this bug.