Closed Bug 983649 Opened 9 years ago Closed 6 years ago

Unable to interact with sub menus using a controller

Categories

(Firefox for Android Graveyard :: General, defect)

30 Branch
All
Android
defect
Not set
major

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 876748

People

(Reporter: timothybeltran515, Unassigned)

References

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/33.0.1750.146 Safari/537.36

Steps to reproduce:

press menu button; go to tools; try to select downloads or add-ons.


Actual results:

Press menu button; go to tools; next screen is not highlighted to move between selections.


Expected results:

press menu; tools; download. open download manager.
OS: Windows 7 → Android
Hardware: x86_64 → All
Ouya console
Also cannot click in sub-menus.
Summary: Pressing the menu button will open the menu but selecting any subsequent option (tools, page) the next box is not highlighted. i.e. downloads, add-ons, apps. Can't be selected. → Sub Menus (tools sub menu and page sub menu) not working.
Also bookmarks submenu is not working, Share sub-menu, etc.
Severity: normal → major
This is navigation with the Ouya controller?
Yes; touchpad cannot select sub menus and neither can the d pad or the joystick.
Blocks: ouya
Summary: Sub Menus (tools sub menu and page sub menu) not working. → Unable to interact with menus and sub menus using the Ouya Controller
It works in menus just not sub-menus.  I can select tools and settings and quit with the touchpad, dpad, and joystick.  Just not the sub-menus.
Thanks. Likewise with your other bug, confirmation of other controllers too would be helpful.
Summary: Unable to interact with menus and sub menus using the Ouya Controller → Unable to interact with sub menus using the Ouya Controller
Confirmed with: Logitech f310 & Dual Action, SGC2909/27 Phillips, IONTICS ID-M100, usb mouse(labtech optical mouse), usb keyboard(filemate 3FNMK2030), and using my cellphone as a touchpad.
Thanks. Seems to be a generic issue related to controller input or focus.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Unable to interact with sub menus using the Ouya Controller → Unable to interact with sub menus using a controller
Its probably a focus issue.  Ouya also has trouble bringing the keyboard to the forefront sometime when you click on text input fields but it can be remedied by clicking the input box multiple times.  Here you have to re-open the menu everytime to get to the sub menu.
Depends on: 985400
No longer depends on: 985400
See Also: → 985400
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 876748
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.