Closed Bug 985400 Opened 6 years ago Closed 6 years ago

Unable to interact with sub menus on LG Optimus 4X HD (4.1.2)/LG G2

Categories

(Firefox for Android :: General, defect)

30 Branch
ARM
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 31
Tracking Status
firefox29 --- unaffected
firefox30 + verified
firefox31 + verified
fennec 30+ ---

People

(Reporter: paul.feher, Assigned: wesj)

References

Details

Attachments

(1 file)

Build:Nightly 31.0a1 (2014-03-18),
Aurora 30.0a2 (2014-03-18)
Device: LG Optimus 4X HD (4.1.2)

Steps to reproduce:
1. Press menu button
2. Go to Page or Tools sub-menu
3. Try to select any option available

Expected Results: 

You are able to select the wanted option.

Actual Results:

The options available can't be selected.

Note: I think this is only a device specific bug since I've only been able to reproduce this issue on my LG Optimus 4X HD (4.1.2) device which possess a hardware menu button. Also it might be related with Bug 983649.
Blocks: 983649
No longer blocks: 983649
See Also: → 983649
tracking-fennec: --- → ?
I think this is related to bug 961954. Sriram moved that code to startup originally for phones with hardware menu buttons.
Assignee: nobody → wjohnston
tracking-fennec: ? → 30+
We have one of these phones in MV.
Kevin, Can you send it to me? Or I may be in mtv Friday...
Commented on IRC. I am not in MV til next week. Best to poke tchung or jsmith before early on Wednesday so it can be sent up by the SF <-> MV courier.
Duplicate of this bug: 989076
LG G2 affected as per bug 989076.
Summary: Unable to interact with sub menus on LG Optimus 4X HD (4.1.2) → Unable to interact with sub menus on LG Optimus 4X HD (4.1.2)/LG G2
Backing out bug 968182 does fix this.
Attached patch PatchSplinter Review
Maybe you know a bit about this Lucas. I'm still trying to figure out what's going wrong tbh.

I noticed that, even though we call close() first this menu smoothly animates between the two lists. i.e. It wasn't actually closing. Posting the show code back to the UI thread fixes the bug. Again, I'm not 100% sure why. Its a sad hack, that may not work on all devices.

Alternatively, we could take the measure code from bug 968182. Or we can keep digging down the hole here.
Attachment #8399704 - Flags: review?(lucasr.at.mozilla)
Tracking - looks like we can consider a backout when 30 heads to beta if there's no fix yet.
Comment on attachment 8399704 [details] [diff] [review]
Patch

Review of attachment 8399704 [details] [diff] [review]:
-----------------------------------------------------------------

Not keen on this hack but I don't have any useful suggestion to make right now (I'd have to dig deeper into our and Android's menu system).
Attachment #8399704 - Flags: review?(lucasr.at.mozilla) → review+
Comment on attachment 8399704 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #):  bug 968182 
User impact if declined: Menu items can't be tapped
Testing completed (on m-c, etc.): Landed on mc now. Needs a little bake time...
Risk to taking this patch (and alternatives if risky): This is pretty low risk. Same code running, just running at a different time. We could backout, but that tickles a different bug (although we have other options there...)
String or IDL/UUID changes made by this patch: None.
Attachment #8399704 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/309c62fdf8ac
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 31
Comment on attachment 8399704 [details] [diff] [review]
Patch

might as well bake on both nightly and aurora to get a bit more feedback - tracking in case we need to backout.
Attachment #8399704 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Flags: needinfo?(paul.feher)
Keywords: verifyme
Verified as fixed on latest Aurora and Nightly on LG Optimus 4x HD(Android 4.1.2).
I am providing the requested information for Paul, since 11.04.2014 was the last day working for Mozilla.
Status: RESOLVED → VERIFIED
Flags: needinfo?(paul.feher)
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.