Closed Bug 983732 Opened 6 years ago Closed 6 years ago

Sync promo footer in bookmarks panel margins are too much

Categories

(Firefox :: Theme, defect)

x86
Windows 7
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 30
Tracking Status
firefox29 --- verified
firefox30 --- verified

People

(Reporter: mikedeboer, Assigned: mikedeboer)

References

()

Details

(Keywords: regression, Whiteboard: [Australis:P3+])

Attachments

(1 file, 1 obsolete file)

+++ This bug was initially created as a clone of Bug #982993 +++

Forgot to revert bug 972550.
No longer blocks: australis-merge
Attached patch Patch (obsolete) — Splinter Review
Mike or Marco, whomever gets here first :))
Attachment #8391320 - Flags: review?(mconley)
Attachment #8391320 - Flags: review?(mak77)
Comment on attachment 8391320 [details] [diff] [review]
Patch

Hm. I'm confused.

Without your patch, the bookmarks promo looks just fine:

http://i.imgur.com/jKtj9zR.png

When I apply your patch, it looks like this:

http://i.imgur.com/eWaSOub.png

What's going on here?
Attachment #8391320 - Flags: review?(mconley)
Attachment #8391320 - Flags: review?(mak77)
Flags: needinfo?(mdeboer)
Ah, I see what's going on... I didn't realize the sync promo is also shown in the bookmarks panel, which I should have.

I will update the patch with a more correct fix; thanks for catching this, Mike!
Flags: needinfo?(mdeboer)
Attachment #8391320 - Attachment is obsolete: true
Attachment #8391716 - Flags: review?(mconley)
Comment on attachment 8391716 [details] [diff] [review]
Patch v2: Put sync promo footer back in the right place

Review of attachment 8391716 [details] [diff] [review]:
-----------------------------------------------------------------

Fixes the issue for me on Win8.
Attachment #8391716 - Flags: review?(mconley) → review+
Muchas gracias, Matt!

Pushed as: https://hg.mozilla.org/integration/fx-team/rev/c56425018cea
Whiteboard: [Australis:P3+] → [Australis:P3+][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/c56425018cea
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P3+][fixed-in-fx-team] → [Australis:P3+]
Target Milestone: --- → Firefox 30
Comment on attachment 8391716 [details] [diff] [review]
Patch v2: Put sync promo footer back in the right place

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 982993 / bug 961727
User impact if declined: sync promo footer looks bad in various panels, where we've just re-enabled it (so it'll hit a lot of users)
Testing completed (on m-c, etc.): on m-c
Risk to taking this patch (and alternatives if risky): very low, CSS-only fix
String or IDL/UUID changes made by this patch: none
Attachment #8391716 - Flags: approval-mozilla-aurora?
Attachment #8391716 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Keywords: verifyme
This issue is verified fixed on Firefox 29 (Build ID: 20140421221237) and Aurora 30 2014-04-24 (Build ID: 20140424004002), using:
 * Windows 7 64-bit [1],
 * Windows 8 Pro 64-bit [2],
 * Ubuntu LTS 14.04 32-bit [3],
 * Mac OS X 10.9 [4].

1. Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0
2. Mozilla/5.0 (Windows NT 6.2; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0
3. Mozilla/5.0 (X11; Linux i686; rv:29.0) Gecko/20100101 Firefox/29.0
4. Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:29.0) Gecko/20100101 Firefox/29.0
Status: RESOLVED → VERIFIED
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.