Closed Bug 983903 Opened 6 years ago Closed 6 years ago

[Gtk3] Ctrl+A doesn't work in textarea or input elements

Categories

(Core :: Widget: Gtk, defect)

x86_64
Linux
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla31
Tracking Status
firefox31 --- verified

People

(Reporter: cork, Assigned: stransky)

References

Details

Attachments

(1 file)

Hitting Ctrl+A to select all the text in input fields or textareas doesn't have any effect.
I wonder if that is not the same as bug 982966
Component: Widget → Widget: Gtk
Is this a recent regression?
I've just recently been able to get gtk3 to build, so can't say. Source from say last month fail to build for me.
(In reply to Karl Tomlinson (:karlt) from comment #2)
> Is this a recent regression?

Didn't happen in Gtk2. This happens in the Gtk3 build - not sure how it worked before. I also just recently switched to building Gtk3 for testing.
(In reply to Hubert Figuiere [:hub] from comment #4)
> (In reply to Karl Tomlinson (:karlt) from comment #2)
> > Is this a recent regression?
> 
> Didn't happen in Gtk2. This happens in the Gtk3 build - not sure how it
> worked before. I also just recently switched to building Gtk3 for testing.

Ya, this is gtk3 only, gtk2 still works just fine for me (same commit)
Attached patch patchSplinter Review
It's because the key theme is bundled for gtk2 only now.
Assignee: nobody → stransky
Comment on attachment 8400040 [details] [diff] [review]
patch

Neil, I see you reviewed this part already, can you check this one please? Thanks.
Attachment #8400040 - Flags: review?(neil)
Seems to work much better with this patch. Thanks !
Comment on attachment 8400040 [details] [diff] [review]
patch

Ah yes, for textfields the XBL handlers get to execute before the native handlers, so you're seeing the emacs handlers in this case. (Note that ehsan recently changed the order for contenteditable regions and design mode documents so that you'll find that Ctrl+A follows the GTK preferences in that case.)
Attachment #8400040 - Flags: review?(neil) → review+
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/7a6baf0853ab
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla31
Hi Cork, would you mind verifying that this is fixed? Thanks!

Mihaela, is this something already in automated tests?
Flags: needinfo?(mihaela.velimiroviciu)
Flags: needinfo?(cork)
Verified fixed in https://hg.mozilla.org/mozilla-central/rev/5fa70bd90a8b
Status: RESOLVED → VERIFIED
Flags: needinfo?(cork)
Duplicate of this bug: 982966
(In reply to Liz Henry :lizzard from comment #12)
> Mihaela, is this something already in automated tests?

Not as far as I am aware of.
Flags: needinfo?(mihaela.velimiroviciu)
Blocks: 1034064
No longer blocks: 1034064
You need to log in before you can comment on or make changes to this bug.