Regression: H.264 video playback yields single visible single frame, video playback aborts; audio continues to work on some 4.3/4.4 devices

RESOLVED DUPLICATE of bug 963621

Status

()

defect
RESOLVED DUPLICATE of bug 963621
5 years ago
2 years ago

People

(Reporter: jsingh121, Assigned: eflores)

Tracking

({regression, reproducible})

28 Branch
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox28? affected, firefox29 unaffected, firefox30 unaffected, fennec28+)

Details

(Whiteboard: [kitkat][jellybean], )

Attachments

(2 attachments)

User Agent: Mozilla/5.0 (Linux; Android 4.3; SM-N900T Build/JSS15J) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/33.0.1750.136 Mobile Safari/537.36

Steps to reproduce:

After the March 11 update to the Android Beta app, going to any video embedded online, including HTML5 images like those hosted on gfycat.com


Actual results:

Only the first frame of the video displays, but sound plays as normal. The video timeline markrer will also stay at 00:00 


Expected results:

The video plays normally.
UA suggests this is on a Galaxy Note 3. Is this correct? Does beta 8 behave as expected? ftp://ftp.mozilla.org/pub/mozilla.org/mobile/releases/28.0b8/
tracking-fennec: --- → ?
Flags: needinfo?(jsingh121)
Status: UNCONFIRMED → NEW
Component: General → Video/Audio
Ever confirmed: true
OS: Linux → Android
Product: Firefox for Android → Core
Hardware: Other → ARM
Summary: In the beta version, in browser videos no longer work and must be opened in another app. → Regression: Video playback yields single visible single frame, video playback aborts; audio continues to work
Version: Firefox 28 → 28 Branch
Posted file log.log
This is reproducible on my Samsung Galaxy S4 (Android 4.4.2)

http://people.mozilla.org/~atrain/mobile/tests/test.mp4
Aurora range

http://hg.mozilla.org/releases/mozilla-aurora/pushloghtml?fromchange=4936f09590a0&tochange=7d1173c4b173

e5785687c13a	Edwin Flores — Bug 953394 - Force OMXCodec to output a sane colour format on Android 4.4 and above. r=doublec, a=bajaj

6da6f218ba17	Edwin Flores — Bug 953394 - Android imports needed for bug 953394. r=doublec, a=bajaj * Added some android::Vector, android::VectorImpl method definitions to link against. * Updated android::Vector and android::VectorImpl headers to 4.4 as using headers from 4.1 crashed 4.4 devices but not vice versa.

a3f8a8d0dc91	Edwin Flores — Bug 953394 - Build changes for OMX support on Android KitKat. r=khuey, a=bajaj

Unfortunately this has been broken since late January and is currently on the 28 train.
Blocks: 953394
I wonder if this is related to the possible patch applying brokenness for 28 in bug 953394?
http://people.mozilla.org/~atrain/mobile/tests/media.html used as a test-page.

This is not reproducible on my Galaxy Note II (Android 4.3).
Whiteboard: [kitkat-only]
This is also not reproducible on my LG Nexus 5 (Android 4.4.2) which I verified against in bug 953394. So it looks like the callout from comment #13 in bug 953394 is truth.

>  Small risk of breaking h.264 on other KitKat devices.
That is correct, I am using a Galaxy Note 3 on Android 4.3 (Jelly Bean).
(In reply to Kevin Brosnan [:kbrosnan] from comment #1)
> UA suggests this is on a Galaxy Note 3. Is this correct? Does beta 8 behave
> as expected? ftp://ftp.mozilla.org/pub/mozilla.org/mobile/releases/28.0b8/

On that test page posted by Aaron Train [:aaronmt], the only things that were affected were those using the H.264 codec. All of those videos displayed the above problem, but the VP9, and MP3 and MP4 audio files functioned normally with timeline tracking.
Flags: needinfo?(jsingh121)
For clarification from the range in comment #3, video playback worked fine prior (on my device) to the introduction of those pushes
Jas, can you confirm if Firefox (27) on Google Play works?
Testing another Android 4.3 device, my Sony Xperia Z

* 27.0 works
* 28.0 does not work
* 29 works
* 30 works

So it looks like 4.3 on some devices is affected too.
Whiteboard: [kitkat-only] → [kitkat][jellybean]
Summary: Regression: Video playback yields single visible single frame, video playback aborts; audio continues to work → Regression: H.264 video playback yields single visible single frame, video playback aborts; audio continues to work
I'm getting the same results. 27.0 works, 28.0 does not.
From my Sony Xperia Tablet Z (4.3)

I/MediaPluginHost( 7740): Android Version is: 18
I/MediaPluginHost( 7740): Android Release Version is: 4.3
I/MediaPluginHost( 7740): Android Device is: SGP311
I/MediaPluginHost( 7740): Android Manufacturer is: Sony
I/MediaPluginHost( 7740): Android Hardware is: qcom
I/MediaPluginHost( 7740): Loading OMX Plugin: libomxpluginkk.so
E/OMX-VDEC-1080P(  319): 
E/OMX-VDEC-1080P(  319):  Error in ioctl read next msg
E/        (  319): 
E/        (  319):  Destroy C2D instance
E/        (  319): 
E/        (  319):  Destroy C2D instance
I/OmxPlugin( 7740): Decoder OMX.qcom.video.decoder.avc can output colour format 0x7fa30c03.
I/        ( 7740): I420ColorConverter: libI420colorconvert.so loaded
I/OmxPlugin( 7740): Colour format 0x7fa30c03 supported by Android I420ColorConverter.
I/OmxPlugin( 7740): Decoder OMX.qcom.video.decoder.avc can output colour format 0x13.
I/OmxPlugin( 7740): Colour format 0x13 supported natively.
I/OmxPlugin( 7740): Found compatible decoder OMX.qcom.video.decoder.avc with colour format 0x13.
I/OMXCodec( 7740): [OMX.qcom.video.decoder.avc] video dimensions are 1920 x 1088
I/OMXCodec( 7740): [OMX.qcom.video.decoder.avc] Crop rect is 1920 x 1088 @ (0, 0)
I/OmxPlugin( 7740): Colour format 0x13 supported natively.
Another point, Samsung Galaxy SII (Android 4.1.2) 27→30 all working for me
Another point, HTC One (Android 4.4.2) 27→30 all working for me
Summary: Regression: H.264 video playback yields single visible single frame, video playback aborts; audio continues to work → Regression: H.264 video playback yields single visible single frame, video playback aborts; audio continues to work on some 4.3/4.4 devices
Missed in comment #3

354c393518fb	Edwin Flores — Bug 866080 - Use Android I420ColorConverter in OMX plugin. r=sotaro, r=doublec, a=lsblakk
(In reply to Kevin Brosnan [:kbrosnan] from comment #1)
> UA suggests this is on a Galaxy Note 3. Is this correct? Does beta 8 behave
> as expected? ftp://ftp.mozilla.org/pub/mozilla.org/mobile/releases/28.0b8/

Confirming that Aaron Train's test video:
http://people.mozilla.org/~atrain/mobile/tests/test.mp4

is broken on Galaxy Note 3 on 4.4.2 Firefox 28 beta 8
but it works on: Galaxy Note 3 on 4.4.2 Firefox 27 release version

and works fine on Nexus 5 Android 4.4.2 Firefox 28 beta 8 and Nexus 5 Firefox 27
As mentioned on IRC, I'm fairly certain this is a dupe of bug 963621, but for some reason ff28 was marked as unaffected at the time.
Flags: needinfo?(edwin)
(In reply to Edwin Flores [:eflores] [:edwin] from comment #17)
> As mentioned on IRC, I'm fairly certain this is a dupe of bug 963621, but
> for some reason ff28 was marked as unaffected at the time.

Firefox 28 was broken at the time of filing.

Re-testing Aurora 28.0a2 (01/24) from the day I filed it, video playback still does not work properly (it's the same as this bug).

Something else is awry here.
Looks like it was mistakingly marked unaffected.
Actually never-mind, I was looking at Beta still. I can confirm that Aurora 28.0a2 (01/24) was broken on the day of filing so it was marked correctly.
Err *not broken*
Is it possible for this warrant a point release update for a fix?
Breaking the Galaxy S4, Galaxy Note 3 and LG G2 https://support.mozilla.org/en-US/questions/990133 makes me believe that a respin is warranted.
I noticed that if you drag the slider during playback on 28 you'll see each new frame from the video, but playback will not carry-forward, I wonder if something else is causing this than.
For whatever reason, for me, on my affected devices mentioned here, this issue on 28 started with the following:

The first bad revision is:
changeset:   161287:354c393518fb
user:        Edwin Flores <eflores@mozilla.com>
date:        Tue Dec 17 11:58:16 2013 +1300
summary:     Bug 866080 - Use Android I420ColorConverter in OMX plugin. r=sotaro, r=doublec, a=lsblakk
Blocks: 866080
No longer blocks: 953394
(In reply to Aaron Train [:aaronmt] from comment #25)
> For whatever reason, for me, on my affected devices mentioned here, this
> issue on 28 started with the following:
> 
> The first bad revision is:
> changeset:   161287:354c393518fb
> user:        Edwin Flores <eflores@mozilla.com>
> date:        Tue Dec 17 11:58:16 2013 +1300
> summary:     Bug 866080 - Use Android I420ColorConverter in OMX plugin.
> r=sotaro, r=doublec, a=lsblakk

This is a bug [1] in Qualcomm's hardware decoder implementation.

Before bug 866080, we didn't support the colour format of the hardware decoder on the affected devices; thus we would fall back to the software decoder, which doesn't have this issue (but is also slow, and lacks support for high profile h264).

After bug 866080, we support the hardware decoder but we this bug, which was fixed in 953394. I'm requesting uplift to release in bug 953394.

[1] Maybe not a bug, but rather an alternative interpretation of the API.
Assignee: nobody → edwin
tracking-fennec: ? → 28+
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 963621
Duplicate of this bug: 985974
You need to log in before you can comment on or make changes to this bug.