Closed Bug 963621 Opened 6 years ago Closed 6 years ago

Regression: No video playback (MP4); Samsung Galaxy S4 (Android 4.4.2) (I420ColorConverter)

Categories

(Core :: Audio/Video, defect)

29 Branch
ARM
Android
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla29
Tracking Status
firefox26 --- unaffected
firefox27 --- unaffected
firefox28 + verified
firefox29 + fixed
fennec 29+ ---

People

(Reporter: aaronmt, Assigned: eflores)

References

()

Details

(Keywords: regression, reproducible, testcase)

Attachments

(4 files)

See attached log-cat for OMX related output.

Of particular interest maybe?

E/OMX-VDEC-1080P(  209): omx_vdec::component_init(): Start of New Playback : role  = OMX.qcom.video.decoder.avc : DEVICE = /dev/msm_vidc_dec

E/OMX-VDEC-1080P(  209): omx_vdec::component_init(): Open returned fd 39, errno 2

Playing the video http://images.apple.com/media/us/mac/30-years/2014/feature/mac-30/mac30-feature-us-20140124_640x360h.mp4 will yield no video playback, however audio will work.

On Firefox 26/27/28 video playback works.

This is reproducible on my Samsung Galaxy S4 (Android 4.4.2) with Nightly (01/24)

Last good revision: 0d11fce4f845 (2013-12-16)
First bad revision: b1e5ade62913 (2013-12-17)
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=0d11fce4f845&tochange=b1e5ade62913
Flags: needinfo?(edwin)
Attached file log
Attachment #8365145 - Attachment mime type: text/x-log → text/plain
sigh.
Assignee: nobody → edwin
Flags: needinfo?(edwin)
We don't have an SGS4 here in the Auckland office. Could you try this build?

http://people.mozilla.org/~eflores/apk/fennec-29.0a1.en-US.android-arm.apk
Flags: needinfo?(aaron.train)
Attached file log-custombuild.log
With the build above, I continue to not see any video playback on my device with the video from comment #0
Flags: needinfo?(aaron.train)
Attached patch 963621.patchSplinter Review
The bug here is with Qualcomm's OMXCodec implementation that hadn't previously surfaced because the hardware decoder was returning a colour format we didn't support at the time.

When we pass the kClientNeedsFramebuffer flag (needed by Samsung and others) to OMXCodec, internally it sets a flag called |mThumbnailMode|. Somebody at qcom (presumably) decided it would be efficient to handle this flag in their OMXCodec implementation by returning a single video frame and then return EOS on subsequent |read()| calls.

This patch just makes sure we don't pass the flag into Qualcomm decoders.
Attachment #8367035 - Flags: review?(chris.double)
Attachment #8367035 - Flags: review?(chris.double) → review+
tracking-fennec: ? → 29+
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/2a7a697f2d88
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla29
Comment on attachment 8367035 [details] [diff] [review]
963621.patch

[Approval Request Comment]
Regression caused by (bug #): bug 866080
User impact if declined: H264 video doesn't work on "Galaxy S4, Galaxy Note 3 and LG G2" (https://bugzilla.mozilla.org/show_bug.cgi?id=984230#c23)
Testing completed (on m-c, etc.): Has been in ff29 since 2014-01-31.
Risk to taking this patch (and alternatives if risky): Video continuing to not work on some devices.
String or IDL/UUID changes made by this patch:
Attachment #8367035 - Flags: approval-mozilla-release?
Mind posting a build for me to test with the patch applied on 28?
(In reply to Aaron Train [:aaronmt] from comment #11)
> Mind posting a build for me to test with the patch applied on 28?

http://people.mozilla.org/~eflores/apk/fennec-28.0.en-US.android-arm.apk
(In reply to Edwin Flores [:eflores] [:edwin] from comment #12)
> (In reply to Aaron Train [:aaronmt] from comment #11)
> > Mind posting a build for me to test with the patch applied on 28?
> 
> http://people.mozilla.org/~eflores/apk/fennec-28.0.en-US.android-arm.apk

Confirmed working on my devices. I still have no idea why when I was testing Aurora 28.0a2 at the time and yesterday again it was not working, oh well.

Lukas, I think we should get this out in a point release.
Flags: needinfo?(lsblakk)
Thanks for the detective work here, I'll get a proposed schedule out tomorrow morning to deal with this in a fennec only dot release.
Flags: needinfo?(lsblakk)
Comment on attachment 8367035 [details] [diff] [review]
963621.patch

Let's get this landed in preparation
Attachment #8367035 - Flags: approval-mozilla-release? → approval-mozilla-release+
Duplicate of this bug: 984230
I'm still seeing this issue - no video playback when playing the video from comment#0 - on Firefox 28.0.1 and Nightly 31.0a1 (2014-04-24) on several devices:
Samsung Galaxy Tab 2 (4.2.2)
Samsung Galaxy Tab (4.0.4)
Samsung Galaxy S3 (4.3) 
Samsung Galaxy Note (4.0.4)
Motorola RAZR XT910 (4.0.4)
ZTE x86 (4.0.4)

I'll attach a log capture from Galaxy Tab 2 playing http://images.apple.com/media/us/mac/30-years/2014/feature/mac-30/mac30-feature-us-20140124_640x360h.mp4   

Also I've tested the files from http://people.mozilla.org/~atrain/mobile/tests/media.html and all of them were played correctly on all devices mentioned above.
Attached file logTab2
I believe that the aforementioned in comment #18 is a seperate issue and not nothing new in regard to video playback on that particular Apple video. In particular, this bug is focused on Qualcomm chipsets.

As in this case, I do not see any frames at all. I see the scrubber and time marker work which wasn't in the case in this particular bug report. Can you please file a new bug? I am able to reproduce an issue with that particular video on my Samsung Galaxy Note II (Android 4.1.2), on all channels including Firefox 27.

As for this bug in particular, I can verify the mozilla-release candidate is working.
Status: RESOLVED → VERIFIED
I filed bug 987223.
You need to log in before you can comment on or make changes to this bug.