Closed Bug 984251 Opened 7 years ago Closed 7 years ago

./bin/gaia-test and Travis-CI unit tests should be working with test_apps

Categories

(Firefox OS Graveyard :: Gaia::TestAgent, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: timdream, Assigned: rickychien)

References

Details

(Whiteboard: [ucid:SystemPlatform47, 1.5, ft:system-platform][gaia-build])

Attachments

(3 files, 2 obsolete files)

+++ This bug was initially created as a clone of Bug #977449 +++
Whiteboard: [ucid:SystemPlatform47, 1.5, ft:system-platform] → [ucid:SystemPlatform47, 1.5, ft:system-platform][gaia-build]
looks we need to patch test-agent, WIPs are coming.
root cause is we only can pass one |path| argument to test-agent by a config file, so WIPs are used to modify |path| to |paths| for our purpose.

WIPs are only for concept so it doesn't work for now.
Assignee: nobody → ricky060709
Status: NEW → ASSIGNED
Component: Gaia::Keyboard → Gaia::TestAgent
OS: Mac OS X → All
Hardware: x86 → All
Summary: [keyboard refactor] ./bin/gaia-test and Travis-CI unit tests should be working with test_apps/demo-keyboard → ./bin/gaia-test and Travis-CI unit tests should be working with test_apps
Attached file Gaia PR
Attachment #8392131 - Attachment is obsolete: true
Attachment #8392132 - Attachment is obsolete: true
Attachment #8393964 - Flags: review?(yurenju.mozilla)
Attached file Js-test-agent PR
Attachment #8393966 - Flags: review?(yurenju.mozilla)
Attached file Gaia-node-modules PR
Attachment #8393967 - Flags: review?(yurenju.mozilla)
The cause has been found due to test-agent only search files in gaia/apps/.
So we can solve this by supporting multiple path search which including gaia/test_apps/.
Attachment #8393967 - Flags: review?(yurenju.mozilla) → review+
Attachment #8393964 - Flags: review?(yurenju.mozilla) → review+
Comment on attachment 8393966 [details] [review]
Js-test-agent PR

Cool! please fix the nits before landed!
Attachment #8393966 - Flags: review?(yurenju.mozilla) → review+
You need to log in before you can comment on or make changes to this bug.