Closed Bug 984504 Opened 8 years ago Closed 8 years ago

support multiple purchases of the same item for server-less payments

Categories

(Marketplace Graveyard :: Payments/Refunds, defect, P2)

x86
macOS
defect

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: kumar, Assigned: jkerim)

References

Details

This is a bug to make sure server-less in-app payments (bug 944480) supports the following scenario:

- Developer creates a product such as a Magical Unicorn for $0.99
- App allows user to buy multiple Magical Unicorns

Does this work as intended? There may be some complexities around receipts but maybe not; maybe it will just work!
Blocks: 944480
Couldn't think of a scenario that affected receipts, testing will tell us.
Depends on: 977767
Priority: -- → P2
Assignee: nobody → jkerim
Tested in my local environment and using unit tests, however unit tests were deemed unnecessary so they will not be merged.

https://github.com/mozilla/zamboni/pull/2201
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.