Closed Bug 98451 Opened 18 years ago Closed 16 years ago

Clean up globals.pl/CGI.pl mess.

Categories

(Bugzilla :: Bugzilla-General, defect, P2, critical)

2.15
defect

Tracking

()

RESOLVED DUPLICATE of bug 87411

People

(Reporter: CodeMachine, Assigned: justdave)

References

Details

The globals and CGI files have become a mess.  They are too big, and
interdependent.

We should separate them into clearly defined files with no cycles.  My
suggestion is as follows:

utilities - this stuff is at the base and is general stuff useful throughout
bugzilla and probably other applications as well

database - may depend on utilities, handles all generic database handling - sql
stuff, database independence, shadow database logic, non-database system
parameters

bugs
users
groups
admin - General files, each relying on utilities and databases.  Things hanging
off bugs like votes and attachments go into bugs.  May have dependencies between
each other but no cycles.

application-general - General application logic - footers, system messages,
error messages.   Relies on the above files.
Let's try to do this near the end of 2.15 when the patch queue is clearer.
Priority: -- → P3
Target Milestone: --- → Bugzilla 2.16
We are currently trying to wrap up Bugzilla 2.16.  We are now close enough to
release time that anything that wasn't already ranked at P1 isn't going to make
the cut.  Thus this is being retargetted at 2.18.  If you strongly disagree with
this retargetting, please comment, however, be aware that we only have about 2
weeks left to review and test anything at this point, and we intend to devote
this time to the remaining bugs that were designated as release blockers.
Target Milestone: Bugzilla 2.16 → Bugzilla 2.18
*** Bug 122891 has been marked as a duplicate of this bug. ***
These should be .pm files, not .pl and we should strive to use CGI.pm (the one
that comes with perl) instead of the current $::FORM stuff.
Severity: normal → critical
Priority: P3 → P2
I'll do DB.pm, which will dynamically use DB::$dbtype.pm once I work out how.
Does this bug actually have any use? It's not a tracking bug, and it seems all
the things it might cover are in other bugs or in people's minds.

Gerv
Actually, I take that back, this is a dupe.  I just didn't do real good finding
it on the first attempt :)

*** This bug has been marked as a duplicate of 87411 ***
No longer blocks: mod_perl
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
Target Milestone: Bugzilla 2.18 → ---
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.