Closed Bug 984625 Opened 7 years ago Closed 7 years ago

[Camera] I cannot clear the self timer

Categories

(Firefox OS Graveyard :: Gaia::Camera, defect)

x86
macOS
defect
Not set
normal

Tracking

(b2g-v1.4 fixed, b2g-v2.0 fixed)

RESOLVED FIXED
1.4 S5 (11apr)
Tracking Status
b2g-v1.4 --- fixed
b2g-v2.0 --- fixed

People

(Reporter: dmarcos, Assigned: dmarcos)

References

Details

Attachments

(1 file)

46 bytes, text/x-github-pull-request
justindarc
: review+
Details | Review
The call e.stopPropagation(); in viewfinder.js prevents the event to bubble app to the application level. The click never gets to the self timer and it cannot be disabled. The only reason for the stopPropagation call is to prevent the filmstrip to be opened when clicking on the viewfinder. The same result can be achieved by removing this.filmstrip.toggle(); in the onViewfinderClick event handler
Attached file Pull Request
Attachment #8392515 - Flags: review?(jdarcangelo)
Attachment #8392515 - Flags: review?(jdarcangelo) → review+
Landed on camera-new-features:

https://github.com/mozilla-b2g/gaia/commit/092ced82a7c50841e7ef3c273700fc0efbd1e97d
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Duplicate of this bug: 985064
Duplicate of this bug: 985072
Assignee: nobody → dmarcos
Bulk edit for camera bugs.

If earlier comments do not show how this bug landed to master, it probably landed as part of https://github.com/mozilla-b2g/gaia/pull/17599 which merged the camera-new-features branch into master.

This bug was uplifted from master to v1.4 as part of https://github.com/mozilla-b2g/gaia/commit/a8190d08e61316a86bba572ba8d894d081a20530
Target Milestone: --- → 1.4 S5 (11apr)
You need to log in before you can comment on or make changes to this bug.