Closed Bug 985006 Opened 7 years ago Closed 7 years ago

[Camera][Madai][QRD Only] Camera Submenu is not displayed properly on rapid back and forth from submenu to camera menu

Categories

(Firefox OS Graveyard :: Gaia::Camera, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:1.4+, b2g-v1.4 fixed, b2g-v2.0 fixed)

RESOLVED FIXED
1.4 S5 (11apr)
blocking-b2g 1.4+
Tracking Status
b2g-v1.4 --- fixed
b2g-v2.0 --- fixed

People

(Reporter: hkoka, Assigned: wilsonpage)

References

()

Details

(Whiteboard: [m+])

Attachments

(3 files)

From Qualcomm testing on QRD 

STR:
1. Run Camera
2. Select Menu
3. Select submenu and select back button quickly and continuously. 

Expected: Submenu should be shown normally. 
Actual: 	Only selected submenu is shown. 

Please try to reproduce with devices that you have (Nexus4, Buri, Helix)
Assignee: nobody → dmarcos
No longer depends on: 984579
Blocks: 985012
No longer blocks: 985012
Wilson, Will you have time to look at this? If not, Diego needs to take this one.
Flags: needinfo?(wilsonpage)
Triage on 3/18: 

Wilsonpage: Unable to reproduce on Hamachi or Nexus4
Leyla: Can you please provide a screenshot.

Mike Vines, please add leyla to this bug.

Thanks
Hema
Flags: needinfo?(mvines)
Unable to repro on Nexus or Hamachi
Flags: needinfo?(wilsonpage)
Attached video Reproduced video
When you select menu, click quickly again and again
Assignee: dmarcos → nobody
Flags: needinfo?(mvines)
It's hard to see what the bug is from the video. At what point does it occur?
Flags: needinfo?(promise09th)
Tagging mike also to see if he can reproduce
Flags: needinfo?(mhabicher)
Summary: [Camera][Madai] Camera Submenu is not displayed properly on rapid back and forth from submenu to camera menu → [Camera][Madai][QRD] Camera Submenu is not displayed properly on rapid back and forth from submenu to camera menu
Definitely confirmed on:
- gecko: larch:cd99991b8d46
- gaia: camera-new-features:db91804c290f7ed40ba5386a73ae3c23b393000c

Wilson, the problem is that rapidly tapping a menu item (e.g. "HDR") and the back button at the top of the menu a bunch of times gets the menu stuck into a state where "HDR" becomes the _only_ menu you can enter, even if you choose another one (e.g. "Grid").

A couple of observations:
- once the problem occurs, it doesn't go away as long as the menu is open
- rotating to landscape and back does not clear the problem
- leaving the menu DOES clear the problem
- it happens with other menu items, not just "HDR"
- rapidly tapping a menu item and back once doesn't seem sufficient to trigger the problem
- there is no obvious UI corruption aside from the incorrect menu always opening
Flags: needinfo?(mhabicher)
Whiteboard: [branch-camera-new-features] → [m+]
Wilson -- please take a look with Mike's input on latest comment
Flags: needinfo?(wilsonpage)
Unable to reproduce on Helix, Hamachi or Nexus4. Is this a QRD only bug?
Attachment #8400628 - Flags: feedback?(mhabicher)
Flags: needinfo?(wilsonpage)
blocking-b2g: --- → 1.4+
Summary: [Camera][Madai][QRD] Camera Submenu is not displayed properly on rapid back and forth from submenu to camera menu → [Camera][Madai][QRD Only] Camera Submenu is not displayed properly on rapid back and forth from submenu to camera menu
Wilson! I can reproduce it on Nexus4 using latest master. 

*Step
1. Click setting menu
2. Click HDR menu
3. Click <HDR of left top (Back button)
4. Repeat 2,3 steps quickly
5. Click Grid Lines -> Menu Lable is HDR

Can Ashish take this issue if you can't reproduce it?
Flags: needinfo?(wilsonpage)
Dear Ashish,

Please take it and try to fix it.
Assignee: nobody → singhashish1887
Flags: needinfo?(wilsonpage)
Flags: needinfo?(promise09th)
Assignee: singhashish1887 → wilsonpage
Attached file pull-request (master)
Attachment #8401990 - Flags: review?(jdarcangelo)
Attachment #8400628 - Flags: feedback?(mhabicher)
Attachment #8401990 - Flags: review?(jdarcangelo) → review+
Landed on 'master': https://github.com/mozilla-b2g/gaia/commit/81f68c40357b4935c42d73a08002a53ad1b5ceac
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
QA Whiteboard: [
Flags: in-moztrap?
QA Whiteboard: [
Flags: in-moztrap? → in-moztrap?(ychung)
New test case needs to be added. There is no existing test case.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
New test created in moztrap:

https://moztrap.mozilla.org/manage/case/14234/
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Flags: in-moztrap?(ychung)
Flags: in-moztrap+
Duplicate of this bug: 993585
You need to log in before you can comment on or make changes to this bug.