Closed Bug 985109 Opened 6 years ago Closed 8 months ago

Properly handle multiple canvas elements on a page in the Canvas Debugger

Categories

(DevTools Graveyard :: Canvas Debugger, defect, P3)

defect

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: vporof, Unassigned)

References

Details

No description provided.
Multiple canvases are not (fully) supported yet. The HTMLCanvasElement prototype methods are instrumented, but recording an animation frame works only on once canvas element at a time. Definitely fixable in a followup, and we should get some nice UI for choosing which canvas to work on.
Depends on: 917226
Damn, you beat me to this. I was just going to file this. CC:ing myself instead :-P
Duplicate of this bug: 1146450
Duplicate of this bug: 1169059
Priority: -- → P3
Product: Firefox → DevTools
The code behind DevTools:Canvas Debugger has gone away. Closing this bug as INVALID
Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → INVALID
Product: DevTools → DevTools Graveyard
You need to log in before you can comment on or make changes to this bug.