Closed Bug 985334 Opened 8 years ago Closed 7 years ago

[Keyboard UX update][User Story] Second layer popup behavior on long press

Categories

(Firefox OS Graveyard :: Gaia::Keyboard, defect, P1)

x86
Gonk (Firefox OS)
defect

Tracking

(b2g-v2.2 fixed)

RESOLVED FIXED
2.1 S4 (12sep)
Tracking Status
b2g-v2.2 --- fixed

People

(Reporter: bhuang, Assigned: rudyl)

References

Details

(Whiteboard: [ucid:SystemPlatform52, ft:system-platform], [p=1])

Attachments

(1 file)

46 bytes, text/x-github-pull-request
timdream
: review+
Omega
: ui-review+
Details | Review
As a user, I want the first letter/symbol candidate to be the same as the short tap option in case I decide not to enter any of the secondary letters or symbols.

Acceptance:
Long press on a key, the first choice should be the key that is pressed.

Refer to p.12 of UX spec in bug 983043
Whiteboard: [ucid:SystemPlatform52, 1.5, ft:system-platform]
See bug 983043 for the UX spec update.
As a discussion during the new spec review, we would need a new design (visual and interaction) for 2-row alternative char menu for this change.

This could be tracked by bug 985334.
Depends on: 934209
(In reply to Rudy Lu [:rudyl] from comment #3)
> As a discussion during the new spec review, we would need a new design
> (visual and interaction) for 2-row alternative char menu for this change.
> 
> This could be tracked by bug 985334.

corrected: This could be tracked by *bug 934209*.
Whiteboard: [ucid:SystemPlatform52, 1.5, ft:system-platform] → [ucid:SystemPlatform52, 2.0, ft:system-platform]
feature-b2g: --- → 2.0
feature-b2g: 2.0 → ---
Whiteboard: [ucid:SystemPlatform52, 2.0, ft:system-platform] → [ucid:SystemPlatform52, ft:system-platform]
Duplicate of this bug: 1021457
Priority: -- → P1
Assignee: nobody → rlu
Target Milestone: --- → 2.1 S1 (1aug)
(In reply to Rudy Lu [:rudyl] from comment #4)
> (In reply to Rudy Lu [:rudyl] from comment #3)
> > As a discussion during the new spec review, we would need a new design
> > (visual and interaction) for 2-row alternative char menu for this change.
> > 
> > This could be tracked by bug 985334.
> 
> corrected: This could be tracked by *bug 934209*.

For the record, we need a 2-row implementation (bug 934209), because we have to include the original key in the alternative char menu, which may cause the length of the menu exceed one row.
e.g. the menu of char 'a' should be '*a* á à â ä å ã ā æ'.
Whiteboard: [ucid:SystemPlatform52, ft:system-platform] → [ucid:SystemPlatform52, ft:system-platform], [p=1]
Target Milestone: 2.1 S1 (1aug) → 2.1 S2 (15aug)
Status: NEW → ASSIGNED
Target Milestone: 2.1 S2 (15aug) → 2.1 S4 (12sep)
Attached file Patch V1
This is a simple patch to include the original key into the alternative char menu.

Tim, could you please help review it (only the 2nd commit)?
Omega, need your help to confirm this UI behavior.
Thank you.
Attachment #8482601 - Flags: ui-review?(ofeng)
Attachment #8482601 - Flags: review?(timdream)
Comment on attachment 8482601 [details] [review]
Patch V1

Good job, thanks!
Attachment #8482601 - Flags: ui-review?(ofeng) → ui-review+
Attachment #8482601 - Flags: review?(timdream) → review+
Landed to Gaia master,
https://github.com/mozilla-b2g/gaia/commit/5422ba94aedb01df0b9c9bca2228e0712b9ad991

--
Thanks for the review!
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Depends on: 1065922
feature-b2g: --- → 2.2+
Remove the feature b2g tag to match the new v2.2 scope.
feature-b2g: 2.2+ → ---
Depends on: 1164820
You need to log in before you can comment on or make changes to this bug.